summaryrefslogtreecommitdiff
path: root/python-crontab
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-02-15 13:29:19 +0100
committerKarel Kočí <cynerd@email.cz>2022-02-15 13:29:19 +0100
commitadf136e41c30971c523088ea71b46f11a616939d (patch)
treea17882162f09a2aa6ee97e9b83911f2394514739 /python-crontab
parent0ed3e2856a5700363e72c9bdfc993d453d409764 (diff)
downloadopenwrt-personal-pkgs-adf136e41c30971c523088ea71b46f11a616939d.tar.gz
openwrt-personal-pkgs-adf136e41c30971c523088ea71b46f11a616939d.tar.bz2
openwrt-personal-pkgs-adf136e41c30971c523088ea71b46f11a616939d.zip
healthcheck: add to test the development version
Diffstat (limited to 'python-crontab')
-rw-r--r--python-crontab/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/python-crontab/Makefile b/python-crontab/Makefile
new file mode 100644
index 0000000..2835b1b
--- /dev/null
+++ b/python-crontab/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-crontab
+PKG_VERSION:=0.23.0
+PKG_RELEASE:=1
+
+PKG_LICENSE:=LGPLv3
+PKG_LICENSE_FILES:=LICENSE
+
+PYPI_NAME:=crontab
+PKG_HASH:=ca79dede9c2f572bb32f38703e8fddcf3427e86edc838f2ffe7ae4b9ee2b0733
+
+include $(TOPDIR)/feeds/packages/lang/python/pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+PYTHON3_PKG_SETUP_ARGS :=
+
+define Package/python3-crontab
+ SECTION:=lang-python
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Parse and use crontab schedules in Python
+ URL:=https://github.com/josiahcarlson/parse-crontab
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python3-crontab/description
+ This package intends to offer a method of parsing crontab schedule entries and
+ determining when an item should next be run. More specifically, it calculates a
+ delay in seconds from when the .next() method is called to when the item should
+ next be executed.
+endef
+
+$(eval $(call Py3Package,python3-crontab))
+$(eval $(call BuildPackage,python3-crontab))
+$(eval $(call BuildPackage,python3-crontab-src))