summaryrefslogtreecommitdiff
path: root/python-chardet/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-02-10 16:06:31 +0100
committerKarel Kočí <cynerd@email.cz>2019-02-10 16:06:31 +0100
commit5f7b7084a81813356006dfe093f834f6072409b3 (patch)
treec1fd2324a63882dd34a6ddd3640fc372d4cef12f /python-chardet/Makefile
parent0103e62bed6a118f9b8935c126790160fe55b02c (diff)
downloadopenwrt-personal-pkgs-5f7b7084a81813356006dfe093f834f6072409b3.tar.gz
openwrt-personal-pkgs-5f7b7084a81813356006dfe093f834f6072409b3.tar.bz2
openwrt-personal-pkgs-5f7b7084a81813356006dfe093f834f6072409b3.zip
Add packages I am pussing to upstream
Diffstat (limited to 'python-chardet/Makefile')
-rw-r--r--python-chardet/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/python-chardet/Makefile b/python-chardet/Makefile
new file mode 100644
index 0000000..ed44fcf
--- /dev/null
+++ b/python-chardet/Makefile
@@ -0,0 +1,36 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-chardet
+PKG_VERSION:=3.0.4
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://pypi.python.org/packages/source/c/chardet/
+PKG_SOURCE:=chardet-$(PKG_VERSION).tar.gz
+PKG_HASH:=84ab92ed1c4d4f16916e05906b6b75a6c0fb5db821cc65e70cbd64a3e2a5eaae
+PKG_LICENSE:=GPLv2.1
+PKG_BUILD_DIR:=$(BUILD_DIR)/chardet-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-chardet
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ URL:=https://github.com/chardet/chardet
+ TITLE:=python3-chardet
+ DEPENDS:=+python3-light
+ VARIANT:=python3
+endef
+
+define Package/python-chardet/description
+ The Universal Character Encoding Detector
+endef
+
+$(eval $(call Py3Package,python3-chardet))
+$(eval $(call BuildPackage,python3-chardet))
+$(eval $(call BuildPackage,python3-chardet-src))