summaryrefslogtreecommitdiff
path: root/personal-pkgs-repo
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-02-11 21:20:09 +0100
committerKarel Kočí <cynerd@email.cz>2019-02-11 21:20:09 +0100
commit32347294b1f463ba8fe84fa672ff87d48576c2c4 (patch)
tree4ed08aedd32e2eaf00edca3b3c00705218f036cb /personal-pkgs-repo
parenta61723d2fbdd509323deb27bb1a90dce125d2ab1 (diff)
downloadopenwrt-personal-pkgs-32347294b1f463ba8fe84fa672ff87d48576c2c4.tar.gz
openwrt-personal-pkgs-32347294b1f463ba8fe84fa672ff87d48576c2c4.tar.bz2
openwrt-personal-pkgs-32347294b1f463ba8fe84fa672ff87d48576c2c4.zip
personal-pkgs-repo: add bigclown for turris-prague
Diffstat (limited to 'personal-pkgs-repo')
-rw-r--r--personal-pkgs-repo/Makefile2
-rw-r--r--personal-pkgs-repo/files/updater.lua5
2 files changed, 6 insertions, 1 deletions
diff --git a/personal-pkgs-repo/Makefile b/personal-pkgs-repo/Makefile
index 97b7d9c..d885bdb 100644
--- a/personal-pkgs-repo/Makefile
+++ b/personal-pkgs-repo/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=personal-pkgs-repo
-PKG_VERSION:=1.3.2
+PKG_VERSION:=1.4
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
diff --git a/personal-pkgs-repo/files/updater.lua b/personal-pkgs-repo/files/updater.lua
index 4993750..1b274e7 100644
--- a/personal-pkgs-repo/files/updater.lua
+++ b/personal-pkgs-repo/files/updater.lua
@@ -31,11 +31,13 @@ Package("personal-pkgs-repo", { replan = "finished" })
local tools = false
local vpn = false
+local bigclown = false
uci_cursor:foreach("system", "system", function(s) hostname = s['hostname'] end)
if hostname == "turris-prague" then
tools = true
vpn = true
+ bigclown = true
Install("6to4")
elseif hostname == "turris-home" then
tools = true
@@ -53,3 +55,6 @@ if vpn then
Install("luci-app-openvpn", "openvpn-openssl")
Install("luci-app-wireguard", "wireguard")
end
+if bigclown then
+ Install("bigclown-gateway", "bigclown-mqtt2influxdb", "bigclown-control-tool")
+end