summaryrefslogtreecommitdiff
path: root/personal-pkgs-repo/files/autopkg-tail.mk
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-08-30 12:37:18 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-08-30 12:37:18 +0200
commitd83bde419809e1836983c8fead7185dfb7689b04 (patch)
treed0e0c8b746a7f24775d9d7f67ab73f2325cec7a6 /personal-pkgs-repo/files/autopkg-tail.mk
parentd7b7793976ee2d1fac1763c224edcc7405168c57 (diff)
downloadopenwrt-personal-pkgs-d83bde419809e1836983c8fead7185dfb7689b04.tar.gz
openwrt-personal-pkgs-d83bde419809e1836983c8fead7185dfb7689b04.tar.bz2
openwrt-personal-pkgs-d83bde419809e1836983c8fead7185dfb7689b04.zip
autopkg: split common
Diffstat (limited to 'personal-pkgs-repo/files/autopkg-tail.mk')
-rw-r--r--personal-pkgs-repo/files/autopkg-tail.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/personal-pkgs-repo/files/autopkg-tail.mk b/personal-pkgs-repo/files/autopkg-tail.mk
new file mode 100644
index 0000000..3b6d104
--- /dev/null
+++ b/personal-pkgs-repo/files/autopkg-tail.mk
@@ -0,0 +1,13 @@
+ifndef AUTOPKG_VARIANT
+ $(error "Don't include autopkg-tail.mk directly!")
+endif
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
+
+undefine TMP_REPO_PATH
+undefine GIT_ARGS
+undefine AUTOPKG_TAIL