summaryrefslogtreecommitdiff
path: root/personal-pkgs-repo/files/autopkg-branch.mk
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2018-08-30 12:42:30 +0200
committerKarel Kočí <karel.koci@nic.cz>2018-08-30 12:52:23 +0200
commit7a4e7809358548e24a5debb375e6e6a368247f79 (patch)
treeb457ae7ba1461966683b28f1f65191443236ee5b /personal-pkgs-repo/files/autopkg-branch.mk
parenta6abd46888c5780377786b50e7a1ca8812ab0960 (diff)
downloadopenwrt-personal-pkgs-7a4e7809358548e24a5debb375e6e6a368247f79.tar.gz
openwrt-personal-pkgs-7a4e7809358548e24a5debb375e6e6a368247f79.tar.bz2
openwrt-personal-pkgs-7a4e7809358548e24a5debb375e6e6a368247f79.zip
autopkg: move it back
Diffstat (limited to 'personal-pkgs-repo/files/autopkg-branch.mk')
-rw-r--r--personal-pkgs-repo/files/autopkg-branch.mk24
1 files changed, 0 insertions, 24 deletions
diff --git a/personal-pkgs-repo/files/autopkg-branch.mk b/personal-pkgs-repo/files/autopkg-branch.mk
deleted file mode 100644
index c8791cc..0000000
--- a/personal-pkgs-repo/files/autopkg-branch.mk
+++ /dev/null
@@ -1,24 +0,0 @@
-# Autopkg tracking given branch
-AUTOPKG_VARIANT:=branch
-$(call include_mk, autopkg-head.mk)
-
-ifndef PKG_SOURCE_BRANCH
-$(error You have to define PKG_SOURCE_BRANCH before pkgauto.mk include)
-endif
-
-PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) rev-parse "$(PKG_SOURCE_BRANCH)")
-PKG_VERSION:=$(shell git $(GIT_ARGS) describe --abbrev=0 --tags "$(PKG_SOURCE_BRANCH)")
-
-ifeq ($(PKG_VERSION),)
-# Count commits since initial commit.
-PKG_RELEASE:=$(shell git $(GIT_ARGS) rev-list --count "$(PKG_SOURCE_VERSION)")
-# No previous version found (no tag) so we use 9999 instead
-PKG_VERSION:=9999
-else
-# Count commits since last version tag
-PKG_RELEASE:=$(shell git $(GIT_ARGS) rev-list --count "$(PKG_VERSION)..$(PKG_SOURCE_VERSION)")
-# .9999 is appended to not collide with possible existing package versions in repository
-PKG_VERSION:=$(PKG_VERSION:v%=%).9999
-endif
-
-$(call include_mk, autopkg-tail.mk)