summaryrefslogtreecommitdiff
path: root/personal-enabler/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-07-26 10:29:15 +0200
committerKarel Kočí <cynerd@email.cz>2020-07-26 10:29:15 +0200
commit0ab34c42554d00099aa50beb1828b0ebaec641af (patch)
tree4df7b82b66e7efd0d55f9d14bba27429908a0ac3 /personal-enabler/Makefile
parentf61f881d6428aa4935d593dcc11bcd25559d510f (diff)
downloadopenwrt-personal-pkgs-0ab34c42554d00099aa50beb1828b0ebaec641af.tar.gz
openwrt-personal-pkgs-0ab34c42554d00099aa50beb1828b0ebaec641af.tar.bz2
openwrt-personal-pkgs-0ab34c42554d00099aa50beb1828b0ebaec641af.zip
personal-enabler: add
Diffstat (limited to 'personal-enabler/Makefile')
-rw-r--r--personal-enabler/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/personal-enabler/Makefile b/personal-enabler/Makefile
new file mode 100644
index 0000000..a592879
--- /dev/null
+++ b/personal-enabler/Makefile
@@ -0,0 +1,34 @@
+#
+## Copyright (C) 2020 Karel Kočí
+#
+## This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+# #
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=personal-enabler
+PKG_VERSION:=1.0.0
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
+
+include $(INCLUDE_DIR)/package.mk
+
+define PKG
+
+define Package/personal-enabler-$(1)
+ TITLE:=Personal configurator: $(1)
+ DEPENDS:=+uci $(2)
+endef
+
+define Package/personal-enabler-$(1)/install
+ $(INSTALL_DIR) $(1)/etc/uci-defaults
+ $(INSTALL_BIN) ./files/$(1).sh $(1)/etc/uci-defaults/60-$(1)
+endef
+
+endef
+
+Build/Compile:=:
+
+$(eval $(call PKG,common,+updater-ng +user-notify))
+$(eval $(call PKG,sentinel,+pkglists +sentinel-proxy))