summaryrefslogtreecommitdiff
path: root/localrepo/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-06-18 14:14:08 +0200
committerKarel Kočí <karel.koci@nic.cz>2019-06-18 14:14:08 +0200
commit2e3e616bf96c08083cde8748c04f2e6d2ed263e1 (patch)
tree1469c53d3b4676e56caacc37f2514b67c21f45b4 /localrepo/Makefile
parent63bdb87a3a269ed0c5cb7fdfb8b9c0a8e4ae76bf (diff)
downloadopenwrt-personal-pkgs-2e3e616bf96c08083cde8748c04f2e6d2ed263e1.tar.gz
openwrt-personal-pkgs-2e3e616bf96c08083cde8748c04f2e6d2ed263e1.tar.bz2
openwrt-personal-pkgs-2e3e616bf96c08083cde8748c04f2e6d2ed263e1.zip
Drop rolling updater for now
Diffstat (limited to 'localrepo/Makefile')
-rw-r--r--localrepo/Makefile41
1 files changed, 0 insertions, 41 deletions
diff --git a/localrepo/Makefile b/localrepo/Makefile
deleted file mode 100644
index c01f6cc..0000000
--- a/localrepo/Makefile
+++ /dev/null
@@ -1,41 +0,0 @@
-#
-## Copyright (C) 2019 CZ.NIC z.s.p.o. (http://www.nic.cz/)
-#
-## This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-# #
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=localrepo
-PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater/localrepo.git
-PKG_SOURCE_BRANCH:=master
-PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
-
-include $(INCLUDE_DIR)/autopkg-branch.mk
-include $(INCLUDE_DIR)/package.mk
-
-define Package/$(PKG_NAME)
- TITLE:=Next generation updater local repository manager
- DEPENDS:=+python3-light
-endef
-
-define Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/localrepo $(1)/usr/bin/localrepo
- $(INSTALL_DIR) $(1)/etc/updater/conf.d
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/localrepo.lua $(1)/etc/updater/conf.d/localrepo.lua
-endef
-
-# Repository should be consistent when updater is executed successfully but this
-# ensures that we will fix any problems that can be caused by older version of
-# localrepo
-define Package/$(PKG_NAME)/postinst
-[ -n "$$IPKG_INSTROOT" ] || {
- localrepo check --fix
-}
-endef
-
-Build/Compile:=
-
-$(eval $(call BuildPackage,$(PKG_NAME)))