summaryrefslogtreecommitdiff
path: root/firewall/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-05-18 22:56:05 +0200
committerKarel Kočí <cynerd@email.cz>2021-05-18 22:56:05 +0200
commit82b6fdad3e720a59a8314e74a9b9f87775ec2514 (patch)
treed1effa25b8af6afaa5cb020609fd43b9032d7252 /firewall/Makefile
parenta15265f77d1cfb1d53de6919a65e5fd73cbeafe2 (diff)
downloadopenwrt-personal-pkgs-82b6fdad3e720a59a8314e74a9b9f87775ec2514.tar.gz
openwrt-personal-pkgs-82b6fdad3e720a59a8314e74a9b9f87775ec2514.tar.bz2
openwrt-personal-pkgs-82b6fdad3e720a59a8314e74a9b9f87775ec2514.zip
firewall: remove for now
Diffstat (limited to 'firewall/Makefile')
-rw-r--r--firewall/Makefile62
1 files changed, 0 insertions, 62 deletions
diff --git a/firewall/Makefile b/firewall/Makefile
deleted file mode 100644
index 012b289..0000000
--- a/firewall/Makefile
+++ /dev/null
@@ -1,62 +0,0 @@
-#
-# Copyright (C) 2013-2016 OpenWrt.org
-# Copyright (C) 2016 LEDE project
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=firewall
-PKG_RELEASE:=4
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL=$(PROJECT_GIT)/project/firewall3.git
-PKG_SOURCE_DATE:=2019-11-22
-PKG_SOURCE_VERSION:=8174814a507489ebbe8bb85c1004e1f02919ca82
-PKG_MIRROR_HASH:=84e0cca2d47470bdb1788a8ae044cc425be8ff650a1137474ba43a15040085da
-PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
-PKG_LICENSE:=ISC
-
-PKG_CONFIG_DEPENDS := CONFIG_IPV6
-
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/cmake.mk
-
-define Package/firewall
- SECTION:=net
- CATEGORY:=Base system
- TITLE:=OpenWrt C Firewall
- DEPENDS:=+libubox +libubus +libuci +libip4tc +IPV6:libip6tc +libxtables +kmod-ipt-core +kmod-ipt-conntrack +IPV6:kmod-nf-conntrack6 +kmod-ipt-nat
-endef
-
-define Package/firewall/description
- This package provides a config-compatible C implementation of the UCI firewall.
-endef
-
-define Package/firewall/conffiles
-/etc/config/firewall
-/etc/firewall.user
-endef
-
-TARGET_CFLAGS += -ffunction-sections -fdata-sections -flto
-TARGET_LDFLAGS += -Wl,--gc-sections -flto
-CMAKE_OPTIONS += $(if $(CONFIG_IPV6),,-DDISABLE_IPV6=1)
-
-define Package/firewall/install
- $(INSTALL_DIR) $(1)/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/firewall3 $(1)/sbin/fw3
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/firewall.init $(1)/etc/init.d/firewall
- $(INSTALL_DIR) $(1)/etc/hotplug.d/iface
- $(INSTALL_CONF) ./files/firewall.hotplug $(1)/etc/hotplug.d/iface/20-firewall
- $(INSTALL_DIR) $(1)/etc/config/
- $(INSTALL_CONF) ./files/firewall.config $(1)/etc/config/firewall
- $(INSTALL_DIR) $(1)/etc/
- $(INSTALL_CONF) ./files/firewall.user $(1)/etc/firewall.user
- $(INSTALL_DIR) $(1)/usr/share/fw3
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/helpers.conf $(1)/usr/share/fw3
-endef
-
-$(eval $(call BuildPackage,firewall))