summaryrefslogtreecommitdiff
path: root/click-log/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-02-10 19:41:47 +0100
committerKarel Kočí <cynerd@email.cz>2019-02-10 19:41:47 +0100
commit55b8c01409913180136b7558ce49ece6059d1351 (patch)
treefff1eb5013b744605319dbfa2033be2d7a9236a6 /click-log/Makefile
parent5378af151872cd5277e8e074c4e09dff2a393c20 (diff)
downloadopenwrt-personal-pkgs-55b8c01409913180136b7558ce49ece6059d1351.tar.gz
openwrt-personal-pkgs-55b8c01409913180136b7558ce49ece6059d1351.tar.bz2
openwrt-personal-pkgs-55b8c01409913180136b7558ce49ece6059d1351.zip
Try to fix bigclown compilation
Diffstat (limited to 'click-log/Makefile')
-rw-r--r--click-log/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/click-log/Makefile b/click-log/Makefile
new file mode 100644
index 0000000..9d4de05
--- /dev/null
+++ b/click-log/Makefile
@@ -0,0 +1,34 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=click-log
+PKG_VERSION:=0.3.2
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://codeload.github.com/click-contrib/click-log/tar.gz/$(PKG_VERSION)?
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_HASH:=16babb66a2ebf22c37c1cf38753a84e6027eb8991fcf9a8487971591b8ca9812
+PKG_LICENSE:=MIT
+
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/python3-click-log
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ URL:=http://github.com/mitsuhiko/click
+ TITLE:=python3-click-log
+ DEPENDS:=+python3-click
+ VARIANT:=python3
+endef
+
+define Package/python3-click-log/description
+ Simple and beautiful logging for click applications
+endef
+
+$(eval $(call Py3Package,python3-click-log))
+$(eval $(call BuildPackage,python3-click-log))