summaryrefslogtreecommitdiff
path: root/bigclown-mqtt2influxdb/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-03-13 10:49:43 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-03-13 10:49:43 +0100
commit8f4ab15987359e4fa4c042e70d30cb093cefce18 (patch)
treef815edc351990f17a6d29f97a286c141520d358c /bigclown-mqtt2influxdb/Makefile
parent01592b391394c87e39b1f41d6437f06ce831ec23 (diff)
downloadopenwrt-personal-pkgs-8f4ab15987359e4fa4c042e70d30cb093cefce18.tar.gz
openwrt-personal-pkgs-8f4ab15987359e4fa4c042e70d30cb093cefce18.tar.bz2
openwrt-personal-pkgs-8f4ab15987359e4fa4c042e70d30cb093cefce18.zip
Drop bigclown packages as they are now in upstream
Diffstat (limited to 'bigclown-mqtt2influxdb/Makefile')
-rw-r--r--bigclown-mqtt2influxdb/Makefile48
1 files changed, 0 insertions, 48 deletions
diff --git a/bigclown-mqtt2influxdb/Makefile b/bigclown-mqtt2influxdb/Makefile
deleted file mode 100644
index a883584..0000000
--- a/bigclown-mqtt2influxdb/Makefile
+++ /dev/null
@@ -1,48 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=bigclown-mqtt2influxdb
-PKG_VERSION:=1.1.0
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=https://codeload.github.com/bigclownlabs/bch-mqtt2influxdb/tar.gz/v$(PKG_VERSION)?
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=5be14132311e85215abbfd732fe6cd652522ea0a343ee8ba7abab3ec7578eb99
-PKG_LICENSE:=MIT
-PKG_BUILD_DIR:=$(BUILD_DIR)/bch-mqtt2influxdb-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-
-define Package/$(PKG_NAME)
- SECTION:=utils
- CATEGORY:=Utilities
- SUBMENU:=BigClown
- URL:=https://github.com/bigclownlabs/bch-mqtt2influxdb
- TITLE:=BigCLown MQTT to Influxdb bridge
- DEPENDS:=+python3-paho-mqtt +python3-yaml +python3-influxdb +python3-jsonpath-ng +python3-schema
-endef
-
-define Py3Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
-
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/init $(1)/etc/init.d/bigclown-mqtt2influxdb
- $(INSTALL_DATA) ./files/config.yml $(1)/etc/bigclown-mqtt2influxdb.yml
-endef
-
-define Package/$(PKG_NAME)/conffiles
-/etc/bigclown-mqtt2influxdb.yml
-endef
-
-define Build/Compile
- sed -i 's/@@VERSION@@/$(PKG_VERSION)/' "$(PKG_BUILD_DIR)/setup.py"
- $(call Py3Build/Compile/Default)
-endef
-
-$(eval $(call Py3Package,$(PKG_NAME)))
-$(eval $(call BuildPackage,$(PKG_NAME)))