summaryrefslogtreecommitdiff
path: root/bigclown-mqtt2influxdb/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-02-10 16:06:31 +0100
committerKarel Kočí <cynerd@email.cz>2019-02-10 16:06:31 +0100
commit5f7b7084a81813356006dfe093f834f6072409b3 (patch)
treec1fd2324a63882dd34a6ddd3640fc372d4cef12f /bigclown-mqtt2influxdb/Makefile
parent0103e62bed6a118f9b8935c126790160fe55b02c (diff)
downloadopenwrt-personal-pkgs-5f7b7084a81813356006dfe093f834f6072409b3.tar.gz
openwrt-personal-pkgs-5f7b7084a81813356006dfe093f834f6072409b3.tar.bz2
openwrt-personal-pkgs-5f7b7084a81813356006dfe093f834f6072409b3.zip
Add packages I am pussing to upstream
Diffstat (limited to 'bigclown-mqtt2influxdb/Makefile')
-rw-r--r--bigclown-mqtt2influxdb/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/bigclown-mqtt2influxdb/Makefile b/bigclown-mqtt2influxdb/Makefile
new file mode 100644
index 0000000..f75ab85
--- /dev/null
+++ b/bigclown-mqtt2influxdb/Makefile
@@ -0,0 +1,45 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bigclown-mqtt2influxdb
+PKG_VERSION:=1.1.0
+PKG_RELEASE:=1
+
+PKG_SOURCE_URL:=https://codeload.github.com/bigclownlabs/bch-mqtt2influxdb/tar.gz/v$(PKG_VERSION)?
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_HASH:=5be14132311e85215abbfd732fe6cd652522ea0a343ee8ba7abab3ec7578eb99
+PKG_LICENSE:=MIT
+PKG_BUILD_DIR:=$(BUILD_DIR)/bch-mqtt2influxdb-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+include ../../../lang/python/python3-package.mk
+
+define Package/$(PKG_NAME)
+ SECTION:=utils
+ CATEGORY:=Utilities
+ SUBMENU:=BigClown
+ URL:=https://github.com/bigclownlabs/bch-mqtt2influxdb
+ TITLE:=BigCLown MQTT to Influxdb bridge
+ DEPENDS:=+python3-paho-mqtt +python3-pyyaml +python3-influxdb +python3-jsonpath-ng +python3-schema
+endef
+
+define Py3Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/init $(1)/etc/init.d/bigclown-mqtt2influxdb
+ $(INSTALL_DATA) ./files/config.yml $(1)/etc/bigclown-mqtt2influxdb.yml
+endef
+
+define Package/$(PKG_NAME)/conffiles
+/etc/bc-mqtt2influxdb.yml
+endef
+
+define Build/Compile
+ sed -i 's/@@VERSION@@/$(PKG_VERSION)/' "$(PKG_BUILD_DIR)/setup.py"
+ $(call Py3Build/Compile/Default)
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))