summaryrefslogtreecommitdiff
path: root/bigclown-mqtt2influxdb/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-03-17 11:28:30 +0100
committerKarel Kočí <cynerd@email.cz>2020-03-17 11:28:30 +0100
commit178871e34d3e5a4da66e469963ef2743f2a4a6df (patch)
treeb40fd9ffb3750a791011d7923f7b057f7b3d2174 /bigclown-mqtt2influxdb/Makefile
parentbeefb9ce0cd7d67589a93dd5abd357ac46955bbc (diff)
downloadopenwrt-personal-pkgs-178871e34d3e5a4da66e469963ef2743f2a4a6df.tar.gz
openwrt-personal-pkgs-178871e34d3e5a4da66e469963ef2743f2a4a6df.tar.bz2
openwrt-personal-pkgs-178871e34d3e5a4da66e469963ef2743f2a4a6df.zip
bigclown-mqtt2influxdb: drop as it is in upstream now
Diffstat (limited to 'bigclown-mqtt2influxdb/Makefile')
-rw-r--r--bigclown-mqtt2influxdb/Makefile49
1 files changed, 0 insertions, 49 deletions
diff --git a/bigclown-mqtt2influxdb/Makefile b/bigclown-mqtt2influxdb/Makefile
deleted file mode 100644
index 02b1c10..0000000
--- a/bigclown-mqtt2influxdb/Makefile
+++ /dev/null
@@ -1,49 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=bigclown-mqtt2influxdb
-PKG_VERSION:=1.3.0
-PKG_RELEASE:=1
-
-PKG_SOURCE_URL:=https://codeload.github.com/bigclownlabs/bch-mqtt2influxdb/tar.gz/v$(PKG_VERSION)?
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=56e1de1f83cb2c5fd5f280c29917c5c25021c36311075c12414733dd0d701697
-PKG_LICENSE:=MIT
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-PKG_BUILD_DIR:=$(BUILD_DIR)/bch-mqtt2influxdb-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-
-define Package/$(PKG_NAME)
- SECTION:=utils
- CATEGORY:=Utilities
- SUBMENU:=BigClown
- URL:=https://github.com/bigclownlabs/bch-mqtt2influxdb
- TITLE:=BigCLown MQTT to Influxdb bridge
- DEPENDS:=+python3-paho-mqtt +python3-yaml +python3-influxdb +python3-jsonpath-ng +python3-schema
-endef
-
-define Py3Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
-
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/init $(1)/etc/init.d/bigclown-mqtt2influxdb
- $(INSTALL_DATA) ./files/config.yml $(1)/etc/bigclown-mqtt2influxdb.yml
-endef
-
-define Package/$(PKG_NAME)/conffiles
-/etc/bigclown-mqtt2influxdb.yml
-endef
-
-define Build/Compile
- sed -i 's/@@VERSION@@/$(PKG_VERSION)/' "$(PKG_BUILD_DIR)/setup.py"
- $(call Py3Build/Compile/Default)
-endef
-
-$(eval $(call Py3Package,$(PKG_NAME)))
-$(eval $(call BuildPackage,$(PKG_NAME)))