summaryrefslogtreecommitdiff
path: root/bigclown-leds
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-03-15 17:41:02 +0100
committerKarel Kočí <cynerd@email.cz>2019-03-15 17:41:28 +0100
commita81bc5429f6f7b743f36f813428a0bc935a28305 (patch)
treebcc63703a93979d41078466dd472b42c98fc1366 /bigclown-leds
parent8f4ab15987359e4fa4c042e70d30cb093cefce18 (diff)
downloadopenwrt-personal-pkgs-a81bc5429f6f7b743f36f813428a0bc935a28305.tar.gz
openwrt-personal-pkgs-a81bc5429f6f7b743f36f813428a0bc935a28305.tar.bz2
openwrt-personal-pkgs-a81bc5429f6f7b743f36f813428a0bc935a28305.zip
Revert "Drop bigclown packages as they are now in upstream"
This reverts commit 8f4ab15987359e4fa4c042e70d30cb093cefce18. But only bihclown-leds part.
Diffstat (limited to 'bigclown-leds')
-rw-r--r--bigclown-leds/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/bigclown-leds/Makefile b/bigclown-leds/Makefile
new file mode 100644
index 0000000..006083e
--- /dev/null
+++ b/bigclown-leds/Makefile
@@ -0,0 +1,36 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bigclown-leds
+PKG_VERSION:=1.0.1
+PKG_RELEASE:=2
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+
+GIT_HASH:=a1236a39e7842ed24b3a9c986dba177d02be5114
+PKG_SOURCE_URL:=https://git.cynerd.cz/bigclown-leds/snapshot/
+PKG_SOURCE:=$(PKG_NAME)-$(GIT_HASH).tar.gz
+PKG_HASH:=9bd59f33c78d1c56f691dd74ab9c16ad98cd1855caecacdc1724e89eec346f67
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(GIT_HASH)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/$(PKG_NAME)
+ TITLE:=BigCLown LEDs
+ DEPENDS:=+python3-paho-mqtt
+endef
+
+define Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bigclown-leds $(1)/usr/bin/bigclown-leds
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bigclown-leds.init $(1)/etc/init.d/bigclown-leds
+endef
+
+define Build/Compile
+ true
+endef
+
+$(eval $(call BuildPackage,$(PKG_NAME)))