summaryrefslogtreecommitdiff
path: root/bigclown-leds
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-03-06 23:48:57 +0100
committerKarel Kočí <cynerd@email.cz>2019-03-06 23:48:57 +0100
commit9e7b7885cbc19e01068503a9bb247b0b8d07b390 (patch)
tree0500eaa285a60a8b693d47d98590052cbda99d78 /bigclown-leds
parent2bd165901c4a6df0f47bf6256ba2ee1960717be7 (diff)
downloadopenwrt-personal-pkgs-9e7b7885cbc19e01068503a9bb247b0b8d07b390.tar.gz
openwrt-personal-pkgs-9e7b7885cbc19e01068503a9bb247b0b8d07b390.tar.bz2
openwrt-personal-pkgs-9e7b7885cbc19e01068503a9bb247b0b8d07b390.zip
bigclown-leds: fix build
Diffstat (limited to 'bigclown-leds')
-rw-r--r--bigclown-leds/Makefile4
-rwxr-xr-xbigclown-leds/files/bigclown-leds32
-rwxr-xr-xbigclown-leds/files/init21
3 files changed, 2 insertions, 55 deletions
diff --git a/bigclown-leds/Makefile b/bigclown-leds/Makefile
index 40d93fc..751493b 100644
--- a/bigclown-leds/Makefile
+++ b/bigclown-leds/Makefile
@@ -24,9 +24,9 @@ endef
define Package/$(PKG_NAME)/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_DATA) ./bigclown-leds $(1)/usr/bin/bigclown-leds
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/bigclown-leds $(1)/usr/bin/bigclown-leds
$(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./bigclown-leds.init $(1)/etc/init.d/bigclown-leds
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/bigclown-leds.init $(1)/etc/init.d/bigclown-leds
endef
define Build/Compile
diff --git a/bigclown-leds/files/bigclown-leds b/bigclown-leds/files/bigclown-leds
deleted file mode 100755
index 8c16ffc..0000000
--- a/bigclown-leds/files/bigclown-leds
+++ /dev/null
@@ -1,32 +0,0 @@
-#!/usr/bin/env python3
-import paho.mqtt.client as mqtt
-
-
-def on_connect(client, userdata, flags, rc):
- print("Connected with result code "+str(rc))
- client.subscribe("node/lcd-thermostat:0/led/#")
-
-
-# The callback for when a PUBLISH message is received from the server.
-def on_message(client, userdata, msg):
- topic = msg.topic[26:]
- client.publish(
- 'node/power-controller:0/led-strip/-/' + topic,
- payload=msg.payload)
-
-#def on_log(mqttc, obj, level, string):
-# print(string)
-
-
-def main():
- client = mqtt.Client()
- client.on_connect = on_connect
- client.on_message = on_message
- #client.on_log = on_log
-
- client.connect("127.0.0.1", 1883, 60)
- client.loop_forever()
-
-
-if __name__ == '__main__':
- main()
diff --git a/bigclown-leds/files/init b/bigclown-leds/files/init
deleted file mode 100755
index fa56a36..0000000
--- a/bigclown-leds/files/init
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/bin/sh /etc/rc.common
-
-START=99
-STOP=1
-
-USE_PROCD=1
-
-PROG=/usr/bin/bigclown-leds
-
-start_service() {
- procd_open_instance
- procd_set_param respawn ${respawn_threshold:-3600} ${respawn_timeout:-5} ${respawn_retry:-5}
- procd_set_param command "$PROG"
- procd_set_param stdout 1
- procd_set_param stderr 1
- procd_close_instance
-}
-
-stop_service() {
- service_stop "$PROG"
-}