summaryrefslogtreecommitdiff
path: root/bigclown-gateway
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-09-12 01:03:07 +0200
committerKarel Kočí <cynerd@email.cz>2018-09-12 01:03:07 +0200
commitff3ddb4a90c2f4fa19c14bc584f2d1300ac52fb3 (patch)
treedcd5a808fc7aafb280d8e33d28272014eeaa4d42 /bigclown-gateway
parentdf3d314797ebc02e0e0ffcd3d53dcc7186964296 (diff)
downloadopenwrt-personal-pkgs-ff3ddb4a90c2f4fa19c14bc584f2d1300ac52fb3.tar.gz
openwrt-personal-pkgs-ff3ddb4a90c2f4fa19c14bc584f2d1300ac52fb3.tar.bz2
openwrt-personal-pkgs-ff3ddb4a90c2f4fa19c14bc584f2d1300ac52fb3.zip
Drop bigclown packages
Diffstat (limited to 'bigclown-gateway')
-rw-r--r--bigclown-gateway/Makefile40
-rw-r--r--bigclown-gateway/files/bc-gateway-usb-dongle.config9
-rwxr-xr-xbigclown-gateway/files/bc-gateway-usb-dongle.init59
3 files changed, 0 insertions, 108 deletions
diff --git a/bigclown-gateway/Makefile b/bigclown-gateway/Makefile
deleted file mode 100644
index 60f659a..0000000
--- a/bigclown-gateway/Makefile
+++ /dev/null
@@ -1,40 +0,0 @@
-#
-## Copyright (C) 2016-2017 CZ.NIC z.s.p.o. (http://www.nic.cz/)
-#
-## This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-# #
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=bigclown-gateway
-PKG_RELEASE:=1
-PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-gateway.git
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-
-include $(TOPDIR)/package/autopkg-tag.mk
-include $(INCLUDE_DIR)/package.mk
-$(call include_mk, python3-package.mk)
-
-define Package/$(PKG_NAME)
- TITLE:=BigCLown gateway
- DEPENDS:=+python3 +mosquitto +mosquitto-client +kmod-usb-serial-ftdi +kmod-usb-acm
-endef
-
-define Py3Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_CONF) ./files/bc-gateway-usb-dongle.config $(1)/etc/config/bc-gateway-usb-dongle
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/bc-gateway-usb-dongle.init $(1)/etc/init.d/bc-gateway-usb-dongle.init
-endef
-
-define Package/$(PKG_NAME)/conffiles
-/etc/config/bc-gateway-usb-dongle
-endef
-
-define Build/Compile
- $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
-endef
-
-$(eval $(call Py3Package,$(PKG_NAME)))
-$(eval $(call BuildPackage,$(PKG_NAME)))
diff --git a/bigclown-gateway/files/bc-gateway-usb-dongle.config b/bigclown-gateway/files/bc-gateway-usb-dongle.config
deleted file mode 100644
index 7fa3977..0000000
--- a/bigclown-gateway/files/bc-gateway-usb-dongle.config
+++ /dev/null
@@ -1,9 +0,0 @@
-
-config config 'gateway'
- option name 'usb-dongle'
- option device '/dev/ttyUSB0'
- option automatic_rename_kit_nodes '1'
-
-config config 'mqtt'
- option host 'localhost'
- option port '1883'
diff --git a/bigclown-gateway/files/bc-gateway-usb-dongle.init b/bigclown-gateway/files/bc-gateway-usb-dongle.init
deleted file mode 100755
index bae6d11..0000000
--- a/bigclown-gateway/files/bc-gateway-usb-dongle.init
+++ /dev/null
@@ -1,59 +0,0 @@
-#!/bin/sh /etc/rc.common
-
-START=99
-STOP=1
-
-USE_PROCD=1
-
-PROG=/usr/bin/bcg
-
-CONF=/tmp/bc-gateway-usb-dongle.generated.conf
-
-UCI_STARTED=
-UCI_DISABLED=
-
-append() {
- local cfg="$1"
- local uci_name="$2"
- local out_name="$3"
- local default="$4"
- config_get val $cfg $uci_name $default
- if [ -n "$val" ]; then
- echo "$out_name $val" >> $CONF
- fi
-}
-
-start_service() {
- config_load bc-gateway-usb-dongle
-
- rm -rf $CONF
- echo "Generating bc-gateway-usb-dongle config file in $CONF"
-
- append gateway name 'name:' usb-dongle
- append gateway device 'device:' /dev/ttyUSB0
- append gateway automatic_rename_kit_nodes 'automatic_rename_kit_nodes:' 1
- append gateway base_topic_prefix 'base_topic_prefix:'
-
- echo "mqtt:" >> $CONF
-
- append mqtt host ' host:' localhost
- append mqtt port ' port:' 1883
- append mqtt cafile ' cafile:'
- append mqtt certfile ' certfile:'
- append mqtt keyfile ' keyfile:'
-
- procd_open_instance
- procd_set_param respawn
- procd_set_param command "$PROG" -c "$CONF" -W
- procd_close_instance
-}
-
-stop_service() {
- service_stop "$PROG"
- ps | grep "$PROG" | grep -v grep | sed -e 's/^\s*\([0-9]\+\)\s.*$/\1/' | xargs -r -- kill -9
-}
-
-service_triggers()
-{
- procd_add_reload_trigger 'bc-gateway-usb-dongle'
-}