summaryrefslogtreecommitdiff
path: root/bigclown-gateway
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-02-04 14:24:08 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-02-04 14:24:08 +0100
commitee1de2a3d1376e1aa19cc4deaaece86b32ab14aa (patch)
tree776190b57b72e62a0eb0ba751aa08ff50e9f21e7 /bigclown-gateway
parent647f5119e89ef2d67f270a954e38633badab1621 (diff)
downloadopenwrt-personal-pkgs-ee1de2a3d1376e1aa19cc4deaaece86b32ab14aa.tar.gz
openwrt-personal-pkgs-ee1de2a3d1376e1aa19cc4deaaece86b32ab14aa.tar.bz2
openwrt-personal-pkgs-ee1de2a3d1376e1aa19cc4deaaece86b32ab14aa.zip
Drop bigclown because I am pushing it upstream
Diffstat (limited to 'bigclown-gateway')
-rw-r--r--bigclown-gateway/Makefile36
-rwxr-xr-xbigclown-gateway/files/bcg9
-rw-r--r--bigclown-gateway/files/config9
-rwxr-xr-xbigclown-gateway/files/init57
4 files changed, 0 insertions, 111 deletions
diff --git a/bigclown-gateway/Makefile b/bigclown-gateway/Makefile
deleted file mode 100644
index 3866ea2..0000000
--- a/bigclown-gateway/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=bigclown-gateway
-PKG_RELEASE:=2
-PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-gateway.git
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-
-include $(INCLUDE_DIR)/autopkg-tag.mk
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-
-define Package/$(PKG_NAME)
- TITLE:=BigCLown gateway
- DEPENDS:=+python3 +mosquitto +mosquitto-client +kmod-usb-serial-ftdi +kmod-usb-acm +python3-paho-mqtt +python3-pyyaml +python3-pyserial +python3-simplejson
-endef
-
-define Py3Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) ./files/bcg $(1)/usr/bin/bcg
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_CONF) ./files/config $(1)/etc/config/bigclown-gateway
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/init $(1)/etc/init.d/bigclown-gateway
-endef
-
-define Package/$(PKG_NAME)/conffiles
-/etc/config/bigclown-gateway
-endef
-
-define Build/Compile
- sed -i 's/@@VERSION@@/$(PKG_VERSION)/' "$(PKG_BUILD_DIR)/setup.py"
- $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
-endef
-
-$(eval $(call Py3Package,$(PKG_NAME)))
-$(eval $(call BuildPackage,$(PKG_NAME)))
diff --git a/bigclown-gateway/files/bcg b/bigclown-gateway/files/bcg
deleted file mode 100755
index fe261f4..0000000
--- a/bigclown-gateway/files/bcg
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/usr/bin/python3.6
-import bcg
-import sys
-from pkg_resources import load_entry_point
-
-if __name__ == '__main__':
- sys.exit(
- load_entry_point('bcg', 'console_scripts', 'bcg')()
- )
diff --git a/bigclown-gateway/files/config b/bigclown-gateway/files/config
deleted file mode 100644
index c16e31b..0000000
--- a/bigclown-gateway/files/config
+++ /dev/null
@@ -1,9 +0,0 @@
-
-config gateway 'gateway'
- option name 'usb-dongle'
- option device '/dev/ttyUSB0'
- option automatic_rename_kit_nodes '1'
-
-config mqtt 'mqtt'
- option host 'localhost'
- option port '1883'
diff --git a/bigclown-gateway/files/init b/bigclown-gateway/files/init
deleted file mode 100755
index 02f27d1..0000000
--- a/bigclown-gateway/files/init
+++ /dev/null
@@ -1,57 +0,0 @@
-#!/bin/sh /etc/rc.common
-
-START=98
-STOP=1
-
-USE_PROCD=1
-
-PROG=/usr/bin/bcg
-CONF=/tmp/etc/bigclown-gateway.conf
-
-append() {
- local cfg="$1"
- local uci_name="$2"
- local out_name="$3"
- local default="$4"
- config_get val $cfg $uci_name $default
- if [ -n "$val" ]; then
- echo "$out_name $val" >> $CONF
- fi
-}
-
-start_service() {
- config_load bigclown-gateway
-
- rm -rf $CONF
- echo "Generating bigclown-gateway config file in $CONF"
-
- append gateway name 'name:' usb-dongle
- # TODO add udev rules and use different default here
- append gateway device 'device:' /dev/ttyUSB0
- append gateway automatic_rename_kit_nodes 'automatic_rename_kit_nodes:' 1
- append gateway base_topic_prefix 'base_topic_prefix:'
-
- echo "mqtt:" >> $CONF
- append mqtt host ' host:' localhost
- append mqtt port ' port:' 1883
- append mqtt cafile ' cafile:'
- append mqtt certfile ' certfile:'
- append mqtt keyfile ' keyfile:'
-
- procd_open_instance
- procd_set_param respawn ${respawn_threshold:-3600} ${respawn_timeout:-5} ${respawn_retry:-5}
- procd_set_param command "$PROG" -c "$CONF" -W
- procd_set_param stdout 1
- procd_set_param stderr 1
- procd_close_instance
-}
-
-stop_service() {
- service_stop "$PROG"
- ps | grep "$PROG" | grep -v grep | sed -e 's/^\s*\([0-9]\+\)\s.*$/\1/' | xargs -r -- kill -9
-}
-
-service_triggers()
-{
- procd_add_reload_trigger 'bc-gateway-usb-dongle'
-}