summaryrefslogtreecommitdiff
path: root/bigclown-gateway
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-09-12 22:09:25 +0200
committerKarel Kočí <cynerd@email.cz>2018-09-12 22:10:34 +0200
commitba6eb4bfe3ab05685ae1289b10b04c9bf8112e35 (patch)
tree418b0c4c4ab167ac9f41a99ed4913ab85a592e82 /bigclown-gateway
parentdab9c4f6f89f4d1b8817375fdb30f0c2cf951989 (diff)
downloadopenwrt-personal-pkgs-ba6eb4bfe3ab05685ae1289b10b04c9bf8112e35.tar.gz
openwrt-personal-pkgs-ba6eb4bfe3ab05685ae1289b10b04c9bf8112e35.tar.bz2
openwrt-personal-pkgs-ba6eb4bfe3ab05685ae1289b10b04c9bf8112e35.zip
bigclown-gateway: Try to fix udev rule and change path
Diffstat (limited to 'bigclown-gateway')
-rw-r--r--bigclown-gateway/Makefile2
-rw-r--r--bigclown-gateway/files/config2
-rwxr-xr-xbigclown-gateway/files/init2
-rw-r--r--bigclown-gateway/files/udev2
4 files changed, 4 insertions, 4 deletions
diff --git a/bigclown-gateway/Makefile b/bigclown-gateway/Makefile
index f5de297..4c41fc5 100644
--- a/bigclown-gateway/Makefile
+++ b/bigclown-gateway/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bigclown-gateway
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-gateway.git
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
diff --git a/bigclown-gateway/files/config b/bigclown-gateway/files/config
index 7fa3977..d880476 100644
--- a/bigclown-gateway/files/config
+++ b/bigclown-gateway/files/config
@@ -1,7 +1,7 @@
config config 'gateway'
option name 'usb-dongle'
- option device '/dev/ttyUSB0'
+ option device '/dev/bcUD0'
option automatic_rename_kit_nodes '1'
config config 'mqtt'
diff --git a/bigclown-gateway/files/init b/bigclown-gateway/files/init
index 090cc06..28f6e7e 100755
--- a/bigclown-gateway/files/init
+++ b/bigclown-gateway/files/init
@@ -27,7 +27,7 @@ start_service() {
append gateway name 'name:' usb-dongle
# TODO add udev rules and use different default here
- append gateway device 'device:' /dev/ttyUSB0
+ append gateway device 'device:' /dev/bcUD0
append gateway automatic_rename_kit_nodes 'automatic_rename_kit_nodes:' 1
append gateway base_topic_prefix 'base_topic_prefix:'
diff --git a/bigclown-gateway/files/udev b/bigclown-gateway/files/udev
index d7a854b..5409c56 100644
--- a/bigclown-gateway/files/udev
+++ b/bigclown-gateway/files/udev
@@ -1 +1 @@
-SUBSYSTEMS=="usb", ACTION=="add", KERNEL=="ttyUSB*", ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6015", ATTRS{serial}=="bc-usb-dongle*", SYMLINK+="bcUD%n", TAG+="systemd", ENV{SYSTEMD_ALIAS}="/dev/bcUD%n"
+SUBSYSTEMS=="usb", ACTION=="add", KERNEL=="ttyUSB*", ATTRS{idVendor}=="0403", ATTRS{idProduct}=="6015", ATTRS{serial}=="bc-usb-dongle*", SYMLINK+="bcUD%n"