summaryrefslogtreecommitdiff
path: root/bigclown-gateway
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-03-13 10:49:43 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-03-13 10:49:43 +0100
commit8f4ab15987359e4fa4c042e70d30cb093cefce18 (patch)
treef815edc351990f17a6d29f97a286c141520d358c /bigclown-gateway
parent01592b391394c87e39b1f41d6437f06ce831ec23 (diff)
downloadopenwrt-personal-pkgs-8f4ab15987359e4fa4c042e70d30cb093cefce18.tar.gz
openwrt-personal-pkgs-8f4ab15987359e4fa4c042e70d30cb093cefce18.tar.bz2
openwrt-personal-pkgs-8f4ab15987359e4fa4c042e70d30cb093cefce18.zip
Drop bigclown packages as they are now in upstream
Diffstat (limited to 'bigclown-gateway')
-rw-r--r--bigclown-gateway/Makefile49
-rw-r--r--bigclown-gateway/files/config10
-rwxr-xr-xbigclown-gateway/files/init58
3 files changed, 0 insertions, 117 deletions
diff --git a/bigclown-gateway/Makefile b/bigclown-gateway/Makefile
deleted file mode 100644
index 32df539..0000000
--- a/bigclown-gateway/Makefile
+++ /dev/null
@@ -1,49 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=bigclown-gateway
-PKG_VERSION:=1.16.2
-PKG_RELEASE:=2
-
-PKG_SOURCE_URL:=https://codeload.github.com/bigclownlabs/bch-gateway/tar.gz/v$(PKG_VERSION)?
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_HASH:=9d3208bf4cffec507d992485104fcbba2b9bc02cf7b290dfe13f98e5916ee1ca
-PKG_LICENSE:=MIT
-PKG_BUILD_DIR:=$(BUILD_DIR)/bch-gateway-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
-
-define Package/$(PKG_NAME)
- SECTION:=utils
- CATEGORY:=Utilities
- SUBMENU:=BigClown
- URL:=https://github.com/bigclownlabs/bch-gateway
- TITLE:=BigCLown gateway
- DEPENDS:=+kmod-usb-serial-ftdi +kmod-usb-acm +python3-click-log +python3-paho-mqtt +python3-pyserial +python3-yaml +python3-simplejson +python3-schema +python3-appdirs
-endef
-
-define Py3Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
-
- $(INSTALL_DIR) $(1)/etc/config
- $(INSTALL_CONF) ./files/config $(1)/etc/config/bigclown-gateway
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_BIN) ./files/init $(1)/etc/init.d/bigclown-gateway
-endef
-
-define Package/$(PKG_NAME)/conffiles
-/etc/config/bigclown-gateway
-endef
-
-define Build/Compile
- sed -i 's/@@VERSION@@/$(PKG_VERSION)/' "$(PKG_BUILD_DIR)/setup.py"
- $(call Py3Build/Compile/Default)
-endef
-
-$(eval $(call Py3Package,$(PKG_NAME)))
-$(eval $(call BuildPackage,$(PKG_NAME)))
diff --git a/bigclown-gateway/files/config b/bigclown-gateway/files/config
deleted file mode 100644
index 6a60ae4..0000000
--- a/bigclown-gateway/files/config
+++ /dev/null
@@ -1,10 +0,0 @@
-
-config gateway 'gateway'
- option enabled '0'
- option name 'usb-dongle'
- option device '/dev/ttyUSB0'
- option automatic_rename_kit_nodes '1'
-
-config mqtt 'mqtt'
- option host 'localhost'
- option port '1883'
diff --git a/bigclown-gateway/files/init b/bigclown-gateway/files/init
deleted file mode 100755
index 37ddd0d..0000000
--- a/bigclown-gateway/files/init
+++ /dev/null
@@ -1,58 +0,0 @@
-#!/bin/sh /etc/rc.common
-
-START=98
-STOP=1
-
-USE_PROCD=1
-
-PROG=/usr/bin/bcg
-CONF=/tmp/etc/bigclown-gateway.conf
-
-append() {
- local cfg="$1"
- local uci_name="$2"
- local out_name="$3"
- local default="$4"
- config_get val $cfg $uci_name $default
- if [ -n "$val" ]; then
- echo "$out_name $val" >> $CONF
- fi
-}
-
-start_service() {
- config_load bigclown-gateway
-
- local enabled
- config_get_bool enabled gateway enabled "0"
- [ "$enabled" = "1" ] || {
- echo "Bigclown gateway service disabled"
- exit 1
- }
-
- rm -rf $CONF
- echo "Generating bigclown-gateway config file in $CONF"
-
- append gateway name 'name:' usb-dongle
- # TODO add hotplug script and use different default here
- append gateway device 'device:' /dev/ttyUSB0
- append gateway automatic_rename_kit_nodes 'automatic_rename_kit_nodes:' 1
- append gateway base_topic_prefix 'base_topic_prefix:'
-
- echo "mqtt:" >> $CONF
- append mqtt host ' host:' localhost
- append mqtt port ' port:' 1883
- append mqtt cafile ' cafile:'
- append mqtt certfile ' certfile:'
- append mqtt keyfile ' keyfile:'
-
- procd_open_instance
- procd_set_param respawn ${respawn_threshold:-3600} ${respawn_timeout:-5} ${respawn_retry:-5}
- procd_set_param command "$PROG" -c "$CONF"
- procd_set_param stdout 1
- procd_set_param stderr 1
- procd_close_instance
-}
-
-service_triggers() {
- procd_add_reload_trigger 'bigclown-gateway'
-}