summaryrefslogtreecommitdiff
path: root/bigclown-gateway/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-09-07 22:56:08 +0200
committerKarel Kočí <cynerd@email.cz>2018-09-07 23:13:58 +0200
commitc3fb448c05022ea78ee59215f3c9aa4dbd859b9f (patch)
treeb450c30ae649b2cb28cbe3676fb642830d134bb4 /bigclown-gateway/Makefile
parentea39800cfac6469212013b2c459f54c3da64c613 (diff)
downloadopenwrt-personal-pkgs-c3fb448c05022ea78ee59215f3c9aa4dbd859b9f.tar.gz
openwrt-personal-pkgs-c3fb448c05022ea78ee59215f3c9aa4dbd859b9f.tar.bz2
openwrt-personal-pkgs-c3fb448c05022ea78ee59215f3c9aa4dbd859b9f.zip
Add BigClown gateway software
Diffstat (limited to 'bigclown-gateway/Makefile')
-rw-r--r--bigclown-gateway/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/bigclown-gateway/Makefile b/bigclown-gateway/Makefile
new file mode 100644
index 0000000..60f659a
--- /dev/null
+++ b/bigclown-gateway/Makefile
@@ -0,0 +1,40 @@
+#
+## Copyright (C) 2016-2017 CZ.NIC z.s.p.o. (http://www.nic.cz/)
+#
+## This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+# #
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=bigclown-gateway
+PKG_RELEASE:=1
+PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-gateway.git
+PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
+
+include $(TOPDIR)/package/autopkg-tag.mk
+include $(INCLUDE_DIR)/package.mk
+$(call include_mk, python3-package.mk)
+
+define Package/$(PKG_NAME)
+ TITLE:=BigCLown gateway
+ DEPENDS:=+python3 +mosquitto +mosquitto-client +kmod-usb-serial-ftdi +kmod-usb-acm
+endef
+
+define Py3Package/$(PKG_NAME)/install
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_CONF) ./files/bc-gateway-usb-dongle.config $(1)/etc/config/bc-gateway-usb-dongle
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/bc-gateway-usb-dongle.init $(1)/etc/init.d/bc-gateway-usb-dongle.init
+endef
+
+define Package/$(PKG_NAME)/conffiles
+/etc/config/bc-gateway-usb-dongle
+endef
+
+define Build/Compile
+ $(call Build/Compile/Py3Mod,,install --prefix="/usr" --root=$(PKG_INSTALL_DIR))
+endef
+
+$(eval $(call Py3Package,$(PKG_NAME)))
+$(eval $(call BuildPackage,$(PKG_NAME)))