summaryrefslogtreecommitdiff
path: root/base64c
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-07-29 11:12:03 +0200
committerKarel Kočí <cynerd@email.cz>2020-07-29 11:12:03 +0200
commit08cf0c0d8eb36dbee9c86717305dea1094394bdd (patch)
tree85b5bd8f8f5de304cac9aa12e06db6233be8a240 /base64c
parent307981ee03e87eccbb0ad46b486d95e5f5bcb8e1 (diff)
downloadopenwrt-personal-pkgs-08cf0c0d8eb36dbee9c86717305dea1094394bdd.tar.gz
openwrt-personal-pkgs-08cf0c0d8eb36dbee9c86717305dea1094394bdd.tar.bz2
openwrt-personal-pkgs-08cf0c0d8eb36dbee9c86717305dea1094394bdd.zip
base64c: remove as avaialbe in upstream
Diffstat (limited to 'base64c')
-rw-r--r--base64c/Makefile58
1 files changed, 0 insertions, 58 deletions
diff --git a/base64c/Makefile b/base64c/Makefile
deleted file mode 100644
index 47f8605..0000000
--- a/base64c/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-#
-## Copyright (C) 2020 CZ.NIC z.s.p.o. (https://www.nic.cz/)
-#
-## This is free software, licensed under the GNU General Public License v3.
-# See /LICENSE for more information.
-# #
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=base64c
-#PKG_VERSION:=0.2.0
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/base64c.git
-#PKG_SOURCE_VERSION:=v$(PKG_VERSION)
-PKG_SOURCE_BRANCH:=master
-
-PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
-PKG_LICENSE:=MIT
-PKG_LICENSE_FILES:=LICENSE
-
-PKG_INSTALL:=1
-PKG_FIXUP:=autoreconf
-
-include $(INCLUDE_DIR)/autopkg-branch.mk
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/autotools.mk
-
-define Package/base64c
- SECTION:=libs
- CATEGORY:=Libraries
- TITLE:=base64c
- URL:=https://gitlab.nic.cz/turris/base64c.git
-endef
-
-define Package/base64c/description
- Base64 encoding/decoding library for C
-endef
-
-CONFIGURE_ARGS += \
- --disable-tests \
- --disable-linters
-
-define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
-
- $(INSTALL_DIR) $(1)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
-endef
-
-define Package/base64c/install
- $(INSTALL_DIR) $(1)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libbase64c.so* $(1)/usr/lib/
-endef
-
-$(eval $(call BuildPackage,base64c))