summaryrefslogtreecommitdiff
path: root/base64c/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-07-23 17:34:40 +0200
committerKarel Kočí <cynerd@email.cz>2020-07-23 17:34:40 +0200
commite7eb55fc16ff68ef77825ba4f1c7f8e3c138e03d (patch)
tree758173d4a67cebc68b3f7b4cf44c2e3c34d2fd6c /base64c/Makefile
parent2911ed4d3c70bc9ef1ad44baabfd3de94897dd7e (diff)
downloadopenwrt-personal-pkgs-e7eb55fc16ff68ef77825ba4f1c7f8e3c138e03d.tar.gz
openwrt-personal-pkgs-e7eb55fc16ff68ef77825ba4f1c7f8e3c138e03d.tar.bz2
openwrt-personal-pkgs-e7eb55fc16ff68ef77825ba4f1c7f8e3c138e03d.zip
base64c: tweak package
Diffstat (limited to 'base64c/Makefile')
-rw-r--r--base64c/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/base64c/Makefile b/base64c/Makefile
index 3bf79bd..0b28ff0 100644
--- a/base64c/Makefile
+++ b/base64c/Makefile
@@ -12,7 +12,7 @@ PKG_NAME:=base64c
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/updater/updater.git
+PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/base64.git
#PKG_SOURCE_VERSION:=v$(PKG_VERSION)
PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
@@ -30,17 +30,13 @@ define Package/base64c
SECTION:=libs
CATEGORY:=Libraries
TITLE:=base64c
+ URL:=https://gitlab.nic.cz/turris/base64.git
endef
CONFIGURE_ARGS += \
--disable-tests \
--disable-linters
-define Package/base64c/install
- $(INSTALL_DIR) $(1)/usr/lib/
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libbase64c.so* $(1)/usr/lib/
-endef
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_BUILD_DIR)/include/* $(1)/usr/include/
@@ -49,4 +45,9 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
endef
+define Package/base64c/install
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libbase64c.so* $(1)/usr/lib/
+endef
+
$(eval $(call BuildPackage,base64c))