summaryrefslogtreecommitdiff
path: root/autopkg-tag.mk
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-09-16 19:36:06 +0200
committerKarel Kočí <cynerd@email.cz>2018-09-16 19:36:06 +0200
commit52c25616fad5d1114aebe4ea6fec0ffc9a0d2e11 (patch)
tree761a3073e1fbc25696febd988cd7f943e922e21e /autopkg-tag.mk
parentff3ddb4a90c2f4fa19c14bc584f2d1300ac52fb3 (diff)
downloadopenwrt-personal-pkgs-52c25616fad5d1114aebe4ea6fec0ffc9a0d2e11.tar.gz
openwrt-personal-pkgs-52c25616fad5d1114aebe4ea6fec0ffc9a0d2e11.tar.bz2
openwrt-personal-pkgs-52c25616fad5d1114aebe4ea6fec0ffc9a0d2e11.zip
pkgauto: Try to fix which tag is marked as latest
Diffstat (limited to 'autopkg-tag.mk')
-rw-r--r--autopkg-tag.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/autopkg-tag.mk b/autopkg-tag.mk
index 11adc22..acfd944 100644
--- a/autopkg-tag.mk
+++ b/autopkg-tag.mk
@@ -2,7 +2,7 @@
AUTOPKG_VARIANT:=tag
include $(TOPDIR)/package/autopkg-head.mk
-PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) tag | grep '^v' | sort | tail -1)
+PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) tag | grep '^v' | sort -n | tail -1)
PKG_VERSION:=$(subst v%,%,$(PKG_SOURCE_VERSION))
include $(TOPDIR)/package/autopkg-tail.mk