summaryrefslogtreecommitdiff
path: root/autopkg-branch.mk
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-02-04 12:55:45 +0100
committerKarel Kočí <karel.koci@nic.cz>2019-02-04 12:55:45 +0100
commit42042f7fb27086042a983a247a34222ead9eae82 (patch)
tree8b6080a51a26c027152cdc55418d301e0e184420 /autopkg-branch.mk
parent896430931c3a1aa9607b0709163f085de3a16064 (diff)
downloadopenwrt-personal-pkgs-42042f7fb27086042a983a247a34222ead9eae82.tar.gz
openwrt-personal-pkgs-42042f7fb27086042a983a247a34222ead9eae82.tar.bz2
openwrt-personal-pkgs-42042f7fb27086042a983a247a34222ead9eae82.zip
Drop autopkg
This is now part of turris-build repository so need to have it here.
Diffstat (limited to 'autopkg-branch.mk')
-rw-r--r--autopkg-branch.mk24
1 files changed, 0 insertions, 24 deletions
diff --git a/autopkg-branch.mk b/autopkg-branch.mk
deleted file mode 100644
index 0e879d1..0000000
--- a/autopkg-branch.mk
+++ /dev/null
@@ -1,24 +0,0 @@
-# Autopkg tracking given branch
-AUTOPKG_VARIANT:=branch
-include $(INCLUDE_DIR)/autopkg-head.mk
-
-ifndef PKG_SOURCE_BRANCH
-$(error You have to define PKG_SOURCE_BRANCH before pkgauto.mk include)
-endif
-
-PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) rev-parse "$(PKG_SOURCE_BRANCH)")
-PKG_VERSION:=$(shell git $(GIT_ARGS) describe --abbrev=0 --tags "$(PKG_SOURCE_BRANCH)")
-
-ifeq ($(PKG_VERSION),)
-# Count commits since initial commit.
-PKG_RELEASE:=$(shell git $(GIT_ARGS) rev-list --count "$(PKG_SOURCE_VERSION)")
-# No previous version found (no tag) so we use 9999 instead
-PKG_VERSION:=9999
-else
-# Count commits since last version tag
-PKG_RELEASE:=$(shell git $(GIT_ARGS) rev-list --count "$(PKG_VERSION)..$(PKG_SOURCE_VERSION)")
-# .9999 is appended to not collide with possible existing package versions in repository
-PKG_VERSION:=$(PKG_VERSION:v%=%).9999
-endif
-
-include $(INCLUDE_DIR)/autopkg-tail.mk