summaryrefslogtreecommitdiff
path: root/argp-standalone/Makefile
diff options
context:
space:
mode:
authorKarel Kočí <karel.koci@nic.cz>2019-04-03 13:44:23 +0200
committerKarel Kočí <karel.koci@nic.cz>2019-04-03 13:44:23 +0200
commite840c2383394182b626c646115d7859b042a4158 (patch)
treebbe3089ae54be5ec67f349f0734da5fb9b8f8359 /argp-standalone/Makefile
parentc160c1f70d48f41ebfd84895f565d87976291071 (diff)
downloadopenwrt-personal-pkgs-e840c2383394182b626c646115d7859b042a4158.tar.gz
openwrt-personal-pkgs-e840c2383394182b626c646115d7859b042a4158.tar.bz2
openwrt-personal-pkgs-e840c2383394182b626c646115d7859b042a4158.zip
Add argp-standalone
Diffstat (limited to 'argp-standalone/Makefile')
-rw-r--r--argp-standalone/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/argp-standalone/Makefile b/argp-standalone/Makefile
new file mode 100644
index 0000000..3fa7e52
--- /dev/null
+++ b/argp-standalone/Makefile
@@ -0,0 +1,32 @@
+#
+## Copyright (C) 2019 CZ.NIC z.s.p.o. (http://www.nic.cz/)
+#
+## This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+# #
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=argp-standalone
+PKG_VERSION:=1.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=argp-standalone-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://www.lysator.liu.se/~nisse/misc
+PKG_HASH:=dec79694da1319acd2238ce95df57f3680fea2482096e483323fddf3d818d8be
+PKG_BUILD_DIR:=$(BUILD_DIR)/argp-standalone-$(PKG_VERSION)
+PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
+
+PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
+
+include $(INCLUDE_DIR)/package.mk
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/libargp.a $(1)/usr/lib/
+ $(INSTALL_DIR) $(1)/usr/include
+ $(CP) $(PKG_BUILD_DIR)/argp.h $(1)/usr/include/
+endef
+
+$(eval $(call Build/DefaultTargets))