summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-10-19 14:37:35 +0200
committerKarel Kočí <cynerd@email.cz>2020-10-19 14:37:35 +0200
commitcb1b57931e787facba5335cc3ca85613089a91cf (patch)
tree34d0f7232599dcbc7cd32970de483953893597e6
parent7e1cb8d0712ba03054fddad121a717cf848be273 (diff)
downloadopenwrt-personal-pkgs-cb1b57931e787facba5335cc3ca85613089a91cf.tar.gz
openwrt-personal-pkgs-cb1b57931e787facba5335cc3ca85613089a91cf.tar.bz2
openwrt-personal-pkgs-cb1b57931e787facba5335cc3ca85613089a91cf.zip
mount-data: remove as I no longer have right now NAS
-rw-r--r--mount-data/Makefile36
-rwxr-xr-xmount-data/files/init24
-rw-r--r--updater.lua1
3 files changed, 0 insertions, 61 deletions
diff --git a/mount-data/Makefile b/mount-data/Makefile
deleted file mode 100644
index 3af25b5..0000000
--- a/mount-data/Makefile
+++ /dev/null
@@ -1,36 +0,0 @@
-#
-## Copyright (C) 2020 Karel Kočí
-#
-## This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-# #
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=mount-data
-PKG_VERSION:=1.0.0
-PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/mount-data
- TITLE:=Mount filesystem to /data directory
-endef
-
-define Package/mount-data/install
- $(INSTALL_DIR) $(1)/etc/init.d
- $(INSTALL_DATA) ./files/init $(1)/etc/init.d/data
-endef
-
-Build/Compile:=:
-
-define Package/mount-data/postinst
-[ -n "$$IPKG_INSTROOT" ] || /etc/init.d/data enable
-endef
-
-define Package/mount-data/prerm
-[ -n "$$IPKG_INSTROOT" ] || /etc/init.d/data disable
-endef
-
-$(eval $(call BuildPackage,mount-data))
diff --git a/mount-data/files/init b/mount-data/files/init
deleted file mode 100755
index d1362e2..0000000
--- a/mount-data/files/init
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh /etc/rc.common
-
-START=36
-STOP=90
-
-status() {
- findmnt >/dev/null /data
-}
-
-start() {
- status || mount -o subvol=@data UUID=7dc606e7-39e0-4320-9ff6-83a10f163e54 /data
-}
-
-stop() {
- umount -fl /data
-}
-
-restart() {
- :
-}
-
-reload() {
- :
-}
diff --git a/updater.lua b/updater.lua
index 09c557e..a183498 100644
--- a/updater.lua
+++ b/updater.lua
@@ -47,7 +47,6 @@ elseif hostname == "turris-home" then
vpn = true
sentinel = true
Install("transmission-daemon-openssl")
- Install("mount-data")
elseif hostname:match("-home$") then
tools = true
elseif hostname:match("^work-") then