summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2020-05-31 11:35:11 +0200
committerKarel Kočí <cynerd@email.cz>2020-05-31 11:35:11 +0200
commit6746e43050c1fce7a44e64e6e9cca583b8308521 (patch)
treed8be1546784dc9b7dd9e82022c541fcc97ed94c9
parent8f4ed24f438b1fb1d308b4d33f9be0cf0cb5cad5 (diff)
downloadopenwrt-personal-pkgs-6746e43050c1fce7a44e64e6e9cca583b8308521.tar.gz
openwrt-personal-pkgs-6746e43050c1fce7a44e64e6e9cca583b8308521.tar.bz2
openwrt-personal-pkgs-6746e43050c1fce7a44e64e6e9cca583b8308521.zip
updater-ng: add new patch for lua
-rw-r--r--updater-ng/patches/0001-configure.ac-fix-check-for-busybox-when-cross-compil.patch (renamed from updater-ng/patches/configure.ac-fix-check-for-busybox-when-cross-compil.patch)2
-rw-r--r--updater-ng/patches/0002-configure.ac-check-for-plain-Lua-first-instead-of-lu.patch29
2 files changed, 30 insertions, 1 deletions
diff --git a/updater-ng/patches/configure.ac-fix-check-for-busybox-when-cross-compil.patch b/updater-ng/patches/0001-configure.ac-fix-check-for-busybox-when-cross-compil.patch
index 0424f0e..e54b550 100644
--- a/updater-ng/patches/configure.ac-fix-check-for-busybox-when-cross-compil.patch
+++ b/updater-ng/patches/0001-configure.ac-fix-check-for-busybox-when-cross-compil.patch
@@ -1,7 +1,7 @@
From 1048eccde0342f5aa3133623f9cafbfa92eaf039 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
Date: Thu, 21 May 2020 21:13:37 +0200
-Subject: [PATCH] configure.ac: fix check for busybox when cross compiling
+Subject: [PATCH 1/2] configure.ac: fix check for busybox when cross compiling
AC_CHECK_FILE works only if cross compilation is not performed. The
reason is that it tries to check for existence of file on native system.
diff --git a/updater-ng/patches/0002-configure.ac-check-for-plain-Lua-first-instead-of-lu.patch b/updater-ng/patches/0002-configure.ac-check-for-plain-Lua-first-instead-of-lu.patch
new file mode 100644
index 0000000..2bf1f47
--- /dev/null
+++ b/updater-ng/patches/0002-configure.ac-check-for-plain-Lua-first-instead-of-lu.patch
@@ -0,0 +1,29 @@
+From 2fd732bc6ed35761142c96122912febc41b021d2 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <cynerd@email.cz>
+Date: Sun, 31 May 2020 11:31:46 +0200
+Subject: [PATCH 2/2] configure.ac: check for plain Lua first instead of lua5.1
+
+Checking for lua with version 5.1 is required for systems with single
+version of Lua while lua5.1 is required for those providing multiple
+versions.
+---
+ configure.ac | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index aec813cb..2cc89aeb 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -23,7 +23,8 @@ AS_IF([test -n "$with_embed_busybox"],
+ AC_DEFINE_UNQUOTED([BUSYBOX_EMBED], [$with_embed_busybox], [Embded Busybox])
+ ])
+
+-PKG_CHECK_MODULES([LUA], [lua5.1])
++PKG_CHECK_MODULES([LUA], [lua = 5.1],,
++ [PKG_CHECK_MODULES([LUA], [lua5.1])])
+ PKG_CHECK_MODULES([LIBEVENT], [libevent >= 2.0])
+ PKG_CHECK_MODULES([LIBARCHIVE], [libarchive])
+ PKG_CHECK_MODULES([LIBCURL], [libcurl])
+--
+2.26.2
+