summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-12-09 12:51:28 +0100
committerKarel Kočí <cynerd@email.cz>2021-12-09 12:51:28 +0100
commit3df1aad296a94639ac36d3da87d52c27a26053a8 (patch)
tree7724c8917b7972a41b3434728a0f6289930070df
parent7c9fbaaed3e46f914fa3d119389095416e6dc6fc (diff)
downloadopenwrt-personal-pkgs-3df1aad296a94639ac36d3da87d52c27a26053a8.tar.gz
openwrt-personal-pkgs-3df1aad296a94639ac36d3da87d52c27a26053a8.tar.bz2
openwrt-personal-pkgs-3df1aad296a94639ac36d3da87d52c27a26053a8.zip
python-uci: test new version
-rw-r--r--python-uci/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/python-uci/Makefile b/python-uci/Makefile
new file mode 100644
index 0000000..ae5df49
--- /dev/null
+++ b/python-uci/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2018-2020 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-uci
+PKG_VERSION:=0.9.0
+PKG_RELEASE:=$(AUTORELEASE)
+
+PKG_SOURCE_URL:=https://gitlab.nic.cz/turris/pyuci.git
+PKG_SOURCE_BRANCH:=euci-type-improve
+
+PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
+PKG_LICENSE:=GPL-3.0-or-later
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/autopkg-branch.mk
+include $(INCLUDE_DIR)/package.mk
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
+
+define Package/python3-uci
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Python UCI bindings
+ URL:=https://gitlab.nic.cz/turris/pyuci/
+ DEPENDS:=+python3-light +libuci
+endef
+
+define Package/python3-uci/description
+ Python3 bindings for Unified Configuration Interface.
+endef
+
+$(eval $(call Py3Package,python3-uci))
+$(eval $(call BuildPackage,python3-uci))
+$(eval $(call BuildPackage,python3-uci-src))