summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2018-10-31 21:42:40 +0100
committerKarel Kočí <cynerd@email.cz>2018-10-31 21:42:40 +0100
commit320996dbf113df5113f9dfab17dfd389a83d4742 (patch)
tree9f959f1f9864df4b0b371273614a6e16510bea9a
parent24d990f9bb9401952bd30619fe5b723019f14e78 (diff)
downloadopenwrt-personal-pkgs-320996dbf113df5113f9dfab17dfd389a83d4742.tar.gz
openwrt-personal-pkgs-320996dbf113df5113f9dfab17dfd389a83d4742.tar.bz2
openwrt-personal-pkgs-320996dbf113df5113f9dfab17dfd389a83d4742.zip
autopkg: move it from feed to include directory
This is preparement to move of autopkg to OpenWRT it self as part of Turris OS hack.
-rw-r--r--autopkg-branch.mk4
-rw-r--r--autopkg-tag.mk4
-rw-r--r--bigclown-control-tools/Makefile4
-rw-r--r--bigclown-gateway/Makefile4
-rw-r--r--bigclown-mqtt2influxdb/Makefile4
-rw-r--r--shellrc/Makefile2
-rw-r--r--updater-ng/Makefile6
7 files changed, 14 insertions, 14 deletions
diff --git a/autopkg-branch.mk b/autopkg-branch.mk
index 9b587b3..0e879d1 100644
--- a/autopkg-branch.mk
+++ b/autopkg-branch.mk
@@ -1,6 +1,6 @@
# Autopkg tracking given branch
AUTOPKG_VARIANT:=branch
-include $(TOPDIR)/feeds/personal/autopkg-head.mk
+include $(INCLUDE_DIR)/autopkg-head.mk
ifndef PKG_SOURCE_BRANCH
$(error You have to define PKG_SOURCE_BRANCH before pkgauto.mk include)
@@ -21,4 +21,4 @@ PKG_RELEASE:=$(shell git $(GIT_ARGS) rev-list --count "$(PKG_VERSION)..$(PKG_SOU
PKG_VERSION:=$(PKG_VERSION:v%=%).9999
endif
-include $(TOPDIR)/feeds/personal/autopkg-tail.mk
+include $(INCLUDE_DIR)/autopkg-tail.mk
diff --git a/autopkg-tag.mk b/autopkg-tag.mk
index 5c7bb28..b4d580c 100644
--- a/autopkg-tag.mk
+++ b/autopkg-tag.mk
@@ -1,6 +1,6 @@
# Autopkg tracking latest version tag
AUTOPKG_VARIANT:=tag
-include $(TOPDIR)/feeds/personal/autopkg-head.mk
+include $(INCLUDE_DIR)/autopkg-head.mk
ifeq ($(PKG_SOURCE_ALL_TAGS),y)
PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) tag | sort -V | tail -1)
@@ -10,4 +10,4 @@ PKG_SOURCE_VERSION:=$(shell git $(GIT_ARGS) tag | grep '^v' | sort -V | tail -1)
PKG_VERSION:=$(subst v%,%,$(PKG_SOURCE_VERSION))
endif
-include $(TOPDIR)/feeds/personal/autopkg-tail.mk
+include $(INCLUDE_DIR)/autopkg-tail.mk
diff --git a/bigclown-control-tools/Makefile b/bigclown-control-tools/Makefile
index e1decb7..764f039 100644
--- a/bigclown-control-tools/Makefile
+++ b/bigclown-control-tools/Makefile
@@ -5,9 +5,9 @@ PKG_RELEASE:=3
PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-control-tool.git
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-include $(TOPDIR)/feeds/personal/autopkg-tag.mk
+include $(INCLUDE_DIR)/autopkg-tag.mk
include $(INCLUDE_DIR)/package.mk
-$(call include_mk, python3-package.mk)
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
define Package/$(PKG_NAME)
TITLE:=BigCLown control tools
diff --git a/bigclown-gateway/Makefile b/bigclown-gateway/Makefile
index 9cfaf3e..3866ea2 100644
--- a/bigclown-gateway/Makefile
+++ b/bigclown-gateway/Makefile
@@ -5,9 +5,9 @@ PKG_RELEASE:=2
PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-gateway.git
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-include $(TOPDIR)/feeds/personal/autopkg-tag.mk
+include $(INCLUDE_DIR)/autopkg-tag.mk
include $(INCLUDE_DIR)/package.mk
-$(call include_mk, python3-package.mk)
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
define Package/$(PKG_NAME)
TITLE:=BigCLown gateway
diff --git a/bigclown-mqtt2influxdb/Makefile b/bigclown-mqtt2influxdb/Makefile
index 5e6f0d2..12829a5 100644
--- a/bigclown-mqtt2influxdb/Makefile
+++ b/bigclown-mqtt2influxdb/Makefile
@@ -5,9 +5,9 @@ PKG_RELEASE:=3
PKG_SOURCE_URL:=https://github.com/bigclownlabs/bch-mqtt2influxdb.git
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-include $(TOPDIR)/feeds/personal/autopkg-tag.mk
+include $(INCLUDE_DIR)/autopkg-tag.mk
include $(INCLUDE_DIR)/package.mk
-$(call include_mk, python3-package.mk)
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
define Package/$(PKG_NAME)
TITLE:=BigCLown MQTT to Influxdb bridge
diff --git a/shellrc/Makefile b/shellrc/Makefile
index 55f7dcb..8b98e7a 100644
--- a/shellrc/Makefile
+++ b/shellrc/Makefile
@@ -12,7 +12,7 @@ PKG_RELEASE:=1
PKG_SOURCE_URL:=https://git.cynerd.cz/shellrc
PKG_MAINTAINER:=Karel Kočí <cynerd@email.cz>
-include $(TOPDIR)/feeds/personal/autopkg-tag.mk
+include $(INCLUDE_DIR)/autopkg-tag.mk
include $(INCLUDE_DIR)/package.mk
define Package/$(PKG_NAME)
diff --git a/updater-ng/Makefile b/updater-ng/Makefile
index ec769c8..d387331 100644
--- a/updater-ng/Makefile
+++ b/updater-ng/Makefile
@@ -14,10 +14,10 @@ PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
HOST_BUILD_DEPENDS:=curl/host libevent2/host lua/host
PKG_BUILD_DEPENDS:=busybox
-include $(TOPDIR)/feeds/personal/autopkg-branch.mk
+include $(INCLUDE_DIR)/autopkg-branch.mk
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
-$(call include_mk, python3-package.mk)
+include $(TOPDIR)/feeds/packages/lang/python/python3-package.mk
define Package/$(PKG_NAME)
TITLE:=The next generation updater
@@ -110,7 +110,7 @@ endef
define Package/$(PKG_NAME)-supervisor
- TITLE:=Next generation updater supervisor and it's library
+ TITLE:=Next generation updater supervisor and its library
DEPENDS:=+updater-ng +vixie-cron +python3-light +python3-uci +userlists +l10n_supported
EXTRA_DEPENDS:=userlists (>=11)
endef