summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2019-04-13 16:53:22 +0200
committerKarel Kočí <cynerd@email.cz>2019-04-13 16:53:22 +0200
commit1255272d199b138fa7cded2d3787755f7213f7a1 (patch)
tree070a83eb1e6cf2aadbc35f48fe33c706e0c3a3cf
parenta0568e0b4bb0fe9b70aecf375473648a7af06f9d (diff)
downloadopenwrt-personal-pkgs-1255272d199b138fa7cded2d3787755f7213f7a1.tar.gz
openwrt-personal-pkgs-1255272d199b138fa7cded2d3787755f7213f7a1.tar.bz2
openwrt-personal-pkgs-1255272d199b138fa7cded2d3787755f7213f7a1.zip
localrepo: sync with upstream
-rw-r--r--localrepo/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/localrepo/Makefile b/localrepo/Makefile
index 3a02bce..c01f6cc 100644
--- a/localrepo/Makefile
+++ b/localrepo/Makefile
@@ -8,34 +8,34 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=localrepo
-PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater/updater.git
+PKG_SOURCE_URL:=https://gitlab.labs.nic.cz/turris/updater/localrepo.git
PKG_SOURCE_BRANCH:=master
PKG_MAINTAINER:=CZ.NIC <packaging@turris.cz>
include $(INCLUDE_DIR)/autopkg-branch.mk
include $(INCLUDE_DIR)/package.mk
-
define Package/$(PKG_NAME)
TITLE:=Next generation updater local repository manager
DEPENDS:=+python3-light
endef
-define Package/$(PKG_NAME)-localrepo/install
+define Package/$(PKG_NAME)/install
$(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/src/localrepo/localrepo $(1)/usr/bin/localrepo
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/localrepo $(1)/usr/bin/localrepo
$(INSTALL_DIR) $(1)/etc/updater/conf.d
- $(INSTALL_CONF) $(PKG_BUILD_DIR)/src/localrepo/localrepo.lua $(1)/etc/updater/conf.d/localrepo.lua
+ $(INSTALL_CONF) $(PKG_BUILD_DIR)/localrepo.lua $(1)/etc/updater/conf.d/localrepo.lua
endef
# Repository should be consistent when updater is executed successfully but this
# ensures that we will fix any problems that can be caused by older version of
# localrepo
-define Package/$(PKG_NAME)-localrepo/postinst
+define Package/$(PKG_NAME)/postinst
[ -n "$$IPKG_INSTROOT" ] || {
localrepo check --fix
}
endef
+Build/Compile:=
$(eval $(call BuildPackage,$(PKG_NAME)))