aboutsummaryrefslogtreecommitdiff
path: root/pkgs/sentinel/proxy/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/sentinel/proxy/default.nix')
-rw-r--r--pkgs/sentinel/proxy/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/sentinel/proxy/default.nix b/pkgs/sentinel/proxy/default.nix
new file mode 100644
index 0000000..5de2836
--- /dev/null
+++ b/pkgs/sentinel/proxy/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, lib, fetchgit
+, autoconf, autoconf-archive, automake, libtool, pkgconfig, gperf
+, openssl, zlib, czmq, libconfig, msgpack, paho-mqtt-c
+}:
+
+stdenv.mkDerivation rec {
+ pname = "sentinel-proxy";
+ version = "1.4";
+ meta = with lib; {
+ homepage = "https://gitlab.nic.cz/turris/sentinel/proxy";
+ description = "Main MQTT Sentinel client. Proxy that lives on the router and relays messages received from ZMQ to uplink server over MQTT channel.";
+ platforms = with platforms; linux;
+ license = licenses.gpl3;
+ };
+
+ src = fetchgit {
+ url = "https://gitlab.nic.cz/turris/sentinel/proxy.git";
+ rev = "v" + version;
+ sha256 = "11s538yf4ydlzlx1vs9fc6hh9igf40s3v853mlcki8a28bni6xwb";
+ };
+
+ buildInputs = [openssl zlib czmq libconfig msgpack paho-mqtt-c];
+ nativeBuildInputs = [
+ autoconf autoconf-archive automake libtool pkgconfig gperf
+ ];
+
+ preConfigure = "./bootstrap";
+}