aboutsummaryrefslogtreecommitdiff
path: root/pkgs/sentinel/certgen/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/sentinel/certgen/default.nix')
-rw-r--r--pkgs/sentinel/certgen/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/sentinel/certgen/default.nix b/pkgs/sentinel/certgen/default.nix
new file mode 100644
index 0000000..bc0b35c
--- /dev/null
+++ b/pkgs/sentinel/certgen/default.nix
@@ -0,0 +1,23 @@
+{ buildPythonApplication, lib, fetchgit
+, python3
+, ipset
+}:
+
+buildPythonApplication rec {
+ pname = "sentinel-dynfw-client";
+ version = "6.2";
+ meta = with lib; {
+ homepage = "https://gitlab.nic.cz/turris/sentinel/certgen";
+ description = "Sentinel automated passwords and certificates retrieval";
+ license = licenses.gpl3;
+ };
+
+ src = fetchgit {
+ url = "https://gitlab.nic.cz/turris/sentinel/certgen.git";
+ rev = "v" + version;
+ sha256 = "10ii3j3wqdib7m2fc0w599981mv9q3ahj96q4kyrn5sh18v2c7nb";
+ };
+
+ # TODO we are missing crypto-wrapper
+ buildInputs = with python3.pkgs; [six requests cryptography];
+}