aboutsummaryrefslogtreecommitdiff
path: root/pkgs/sentinel/certgen/default.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-01-02 17:23:58 +0100
committerKarel Kočí <cynerd@email.cz>2022-04-12 21:48:06 +0200
commit5339e045194c5ad482250c0271959a5fd9f97db2 (patch)
tree44d068a2c15b4683f0eb124044bf8c59bda398d1 /pkgs/sentinel/certgen/default.nix
parent00e3489cc7ea1edc3e71aaa94a62efbd13d65e49 (diff)
downloadnixturris-5339e045194c5ad482250c0271959a5fd9f97db2.tar.gz
nixturris-5339e045194c5ad482250c0271959a5fd9f97db2.tar.bz2
nixturris-5339e045194c5ad482250c0271959a5fd9f97db2.zip
nios: Add sentinel module
Diffstat (limited to 'pkgs/sentinel/certgen/default.nix')
-rw-r--r--pkgs/sentinel/certgen/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/sentinel/certgen/default.nix b/pkgs/sentinel/certgen/default.nix
new file mode 100644
index 0000000..bc0b35c
--- /dev/null
+++ b/pkgs/sentinel/certgen/default.nix
@@ -0,0 +1,23 @@
+{ buildPythonApplication, lib, fetchgit
+, python3
+, ipset
+}:
+
+buildPythonApplication rec {
+ pname = "sentinel-dynfw-client";
+ version = "6.2";
+ meta = with lib; {
+ homepage = "https://gitlab.nic.cz/turris/sentinel/certgen";
+ description = "Sentinel automated passwords and certificates retrieval";
+ license = licenses.gpl3;
+ };
+
+ src = fetchgit {
+ url = "https://gitlab.nic.cz/turris/sentinel/certgen.git";
+ rev = "v" + version;
+ sha256 = "10ii3j3wqdib7m2fc0w599981mv9q3ahj96q4kyrn5sh18v2c7nb";
+ };
+
+ # TODO we are missing crypto-wrapper
+ buildInputs = with python3.pkgs; [six requests cryptography];
+}