aboutsummaryrefslogtreecommitdiff
path: root/pkgs/patches-linux-5.15/302-mips_no_branch_likely.patch
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/patches-linux-5.15/302-mips_no_branch_likely.patch')
-rw-r--r--pkgs/patches-linux-5.15/302-mips_no_branch_likely.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/pkgs/patches-linux-5.15/302-mips_no_branch_likely.patch b/pkgs/patches-linux-5.15/302-mips_no_branch_likely.patch
new file mode 100644
index 0000000..271923f
--- /dev/null
+++ b/pkgs/patches-linux-5.15/302-mips_no_branch_likely.patch
@@ -0,0 +1,22 @@
+From: Felix Fietkau <nbd@nbd.name>
+Subject: mips: use -mno-branch-likely for kernel and userspace
+
+saves ~11k kernel size after lzma and ~12k squashfs size in the
+
+lede-commit: 41a039f46450ffae9483d6216422098669da2900
+Signed-off-by: Felix Fietkau <nbd@nbd.name>
+---
+ arch/mips/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/arch/mips/Makefile
++++ b/arch/mips/Makefile
+@@ -95,7 +95,7 @@ all-$(CONFIG_SYS_SUPPORTS_ZBOOT)+= vmlin
+ # machines may also. Since BFD is incredibly buggy with respect to
+ # crossformat linking we rely on the elf2ecoff tool for format conversion.
+ #
+-cflags-y += -G 0 -mno-abicalls -fno-pic -pipe
++cflags-y += -G 0 -mno-abicalls -fno-pic -pipe -mno-branch-likely
+ cflags-y += -msoft-float
+ LDFLAGS_vmlinux += -G 0 -static -n -nostdlib
+ KBUILD_AFLAGS_MODULE += -mlong-calls