aboutsummaryrefslogtreecommitdiff
path: root/pkgs/libraries/logc-libs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/libraries/logc-libs/default.nix')
-rw-r--r--pkgs/libraries/logc-libs/default.nix29
1 files changed, 0 insertions, 29 deletions
diff --git a/pkgs/libraries/logc-libs/default.nix b/pkgs/libraries/logc-libs/default.nix
deleted file mode 100644
index f8e4a57..0000000
--- a/pkgs/libraries/logc-libs/default.nix
+++ /dev/null
@@ -1,29 +0,0 @@
-{ stdenv, lib, fetchgit
-, bootstrapHook, pkg-config
-, logc, czmq, libevent
-, check
-}:
-
-stdenv.mkDerivation rec {
- pname = "logc-libs";
- version = "0.1.0";
- meta = with lib; {
- homepage = "https://gitlab.nic.cz/turris/logc-libs";
- description = "Logging for C";
- license = licenses.mit;
- };
-
- src = fetchgit {
- url = "https://gitlab.nic.cz/turris/logc-libs.git";
- rev = "v" + version;
- sha256 = "11b89742k81wbb0mc4r13l2sviz720qgl06v4wnjwlmi9x4pzy1a";
- };
-
- buildInputs = [logc czmq libevent];
- nativeBuildInputs = [bootstrapHook pkg-config];
- depsBuildBuild = [check];
-
- doCheck = false; # TODO the test fails due to errno being set by czmq for some reason
- doInstallCheck = false;
- configureFlags = lib.optional (stdenv.hostPlatform == stdenv.buildPlatform) "--enable-tests";
-}