aboutsummaryrefslogtreecommitdiff
path: root/pkgs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/default.nix')
-rw-r--r--pkgs/default.nix15
1 files changed, 8 insertions, 7 deletions
diff --git a/pkgs/default.nix b/pkgs/default.nix
index b16795d..41c28c8 100644
--- a/pkgs/default.nix
+++ b/pkgs/default.nix
@@ -16,22 +16,23 @@ let
# Crypto and certificates
libatsha204 = callPackage ./libatsha204 { };
mox-otp = python3Packages.callPackage ./mox-otp { };
- #crypto-wrapper = callPackage ./crypto-wrapper { };
+ crypto-wrapper = callPackage ./crypto-wrapper { };
#certgen = python3Packages.callPackage ./certgen { };
# NOR Firmwares
- ubootTurrisMox = buildUBoot {
- defconfig = "turris_mox_defconfig";
- extraMeta.platforms = ["aarch64-linux"];
- filesToInstall = ["u-boot.bin"];
- extraPatches = [ ./patches/include-configs-turris_mox-increase-space-for-the-ke.patch ];
- };
armTrustedFirmwareTurrisMox = buildArmTrustedFirmware rec {
platform = "a3700";
extraMeta.platforms = ["aarch64-linux"];
extraMakeFlags = ["USE_COHERENT_MEM=0" "CM3_SYSTEM_RESET=1" "FIP_ALIGN=0x100"];
filesToInstall = ["build/${platform}/release/bl31.bin"];
};
+ ubootTurrisMox = buildUBoot {
+ defconfig = "turris_mox_defconfig";
+ extraMeta.platforms = ["aarch64-linux"];
+ filesToInstall = ["u-boot.bin"];
+ extraPatches = [ ./patches/include-configs-turris_mox-increase-space-for-the-ke.patch ];
+ BL31 = "${armTrustedFirmwareTurrisMox}/bl31.bin";
+ };
ubootTurrisOmnia = buildUBoot {
defconfig = "turris_omnia_defconfig";
extraMeta.platforms = ["armv7l-linux"];