aboutsummaryrefslogtreecommitdiff
path: root/pkgs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/default.nix')
-rw-r--r--pkgs/default.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/pkgs/default.nix b/pkgs/default.nix
index be0cc4f..082cca1 100644
--- a/pkgs/default.nix
+++ b/pkgs/default.nix
@@ -1,8 +1,11 @@
{ nixpkgs ? <nixpkgs>, nixlib ? nixpkgs.lib }:
+with builtins;
+with nixlib;
+
let
pkgs = nixpkgs // turrispkgs;
- callPackage = nixlib.callPackageWith pkgs;
+ callPackage = callPackageWith pkgs;
turrispkgs = with pkgs; {
@@ -11,6 +14,14 @@ let
mox-otp = python3Packages.callPackage ./mox-otp { };
crypto-wrapper = callPackage ./crypto-wrapper { };
+ # Turris kernels with patches
+ linux_turris_5_15 = callPackage
+ "${nixpkgs.path}/pkgs/os-specific/linux/kernel/linux-5.15.nix" {
+ kernelPatches = map (p: { name = toString p; patch = ./patches-linux-5.15 + "/${p}"; }) (
+ attrNames (filterAttrs (n: v: v == "regular") (
+ readDir ./patches-linux-5.15)));
+ };
+
# NOR Firmwares
armTrustedFirmwareTurrisMox = buildArmTrustedFirmware rec {
platform = "a3700";