aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/turris-wifi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/turris-wifi.nix')
-rw-r--r--nixos/modules/turris-wifi.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/nixos/modules/turris-wifi.nix b/nixos/modules/turris-wifi.nix
new file mode 100644
index 0000000..bd74523
--- /dev/null
+++ b/nixos/modules/turris-wifi.nix
@@ -0,0 +1,33 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+let
+
+ cnf = config.turris.wifi;
+
+in {
+
+ options = {
+ turris.wifi = {
+ enable = mkOption {
+ type = types.bool;
+ default = true;
+ description = "Enable Turris WiFi configuration";
+ };
+ };
+ };
+
+ config = mkIf cnf.enable {
+ # Needed for Ath10k firmware
+ hardware.firmware = with pkgs; [ firmwareLinuxNonfree ];
+
+ # The additional administration packages
+ environment.systemPackages = with pkgs; [
+ iw
+ ] ++ optionals (config.turris.board == "mox") [
+ ] ++ optionals (config.turris.board == "omnia") [
+ ];
+
+ };
+}