aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/turris-omnia-support.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/turris-omnia-support.nix')
-rw-r--r--nixos/modules/turris-omnia-support.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/nixos/modules/turris-omnia-support.nix b/nixos/modules/turris-omnia-support.nix
new file mode 100644
index 0000000..b68affc
--- /dev/null
+++ b/nixos/modules/turris-omnia-support.nix
@@ -0,0 +1,28 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ config = mkIf (config.turris.board == "omnia") {
+ # Use early print to the serial console
+ boot.kernelParams = [
+ "earlyprintk" "console=ttyS0,115200"
+ ];
+ # Custom kernel config
+ boot.kernelPatches = [{
+ name = "omnia";
+ patch = null;
+ extraConfig = ''
+ LEDS_CLASS_MULTICOLOR y
+ LEDS_TURRIS_OMNIA y
+ '';
+ }];
+
+ # The additional administration packages
+ environment.systemPackages = with pkgs; [
+ libatsha204
+ ];
+
+ };
+}