aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/turris-mox-support.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/turris-mox-support.nix')
-rw-r--r--nixos/modules/turris-mox-support.nix8
1 files changed, 7 insertions, 1 deletions
diff --git a/nixos/modules/turris-mox-support.nix b/nixos/modules/turris-mox-support.nix
index 578e467..c3fd508 100644
--- a/nixos/modules/turris-mox-support.nix
+++ b/nixos/modules/turris-mox-support.nix
@@ -10,10 +10,16 @@ with lib;
"earlycon=ar3700_uart,0xd0012000" "console=ttyMV0,115200"
"pcie_aspm=off" # Fix for crashes due to SError Interrupt on ath10k load
];
+ # Insert these modules early. The watchdog should be handled as soon as
+ # possible and moxtet is for some reason ignored otherwise.
+ boot.initrd.kernelModules = [
+ "armada_37xx_wdt"
+ "moxtet" "gpio-moxtet" "turris-mox-rwtm"
+ ];
# The additional administration packages
environment.systemPackages = with pkgs; [
- #mox-otp
+ mox-otp
];
};