aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/turris-mox-support.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/turris-mox-support.nix')
-rw-r--r--nixos/modules/turris-mox-support.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/nixos/modules/turris-mox-support.nix b/nixos/modules/turris-mox-support.nix
new file mode 100644
index 0000000..9596b15
--- /dev/null
+++ b/nixos/modules/turris-mox-support.nix
@@ -0,0 +1,29 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ config = mkIf (config.turris.board == "mox") {
+ # Use early print to the serial console
+ boot.kernelParams = [
+ "earlycon=ar3700_uart,0xd0012000" "console=ttyMV0,115200"
+ "pcie_aspm=off" # Fix for crashes due to SError Interrupt on ath10k load
+ ];
+ # Custom kernel config
+ boot.kernelPatches = [{
+ name = "rwtm";
+ patch = null;
+ extraConfig = ''
+ TURRIS_MOX_RWTM y
+ ARMADA_37XX_RWTM_MBOX y
+ '';
+ }];
+
+ # The additional administration packages
+ environment.systemPackages = with pkgs; [
+ #mox-otp
+ ];
+
+ };
+}