aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/kernel-patches.nix
diff options
context:
space:
mode:
Diffstat (limited to 'nixos/modules/kernel-patches.nix')
-rw-r--r--nixos/modules/kernel-patches.nix40
1 files changed, 40 insertions, 0 deletions
diff --git a/nixos/modules/kernel-patches.nix b/nixos/modules/kernel-patches.nix
new file mode 100644
index 0000000..516508c
--- /dev/null
+++ b/nixos/modules/kernel-patches.nix
@@ -0,0 +1,40 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+ config = {
+ # Kernel patches from Turris OS
+ boot.kernelPatches = [{
+ name = "ARM-dts-turris-omnia-enable-LED-controller-node";
+ patch = ./kernel-patches/0001-ARM-dts-turris-omnia-enable-LED-controller-node.patch;
+ }{
+ name = "leds-turris-omnia-support-HW-controlled-mode-via-pri";
+ patch = ./kernel-patches/0002-leds-turris-omnia-support-HW-controlled-mode-via-pri.patch;
+ }{
+ name = "leds-turris-omnia-initialize-multi-intensity-to-full";
+ patch = ./kernel-patches/0003-leds-turris-omnia-initialize-multi-intensity-to-full.patch;
+ }{
+ name = "leds-turris-omnia-change-max-brightness-from-255-to-";
+ patch = ./kernel-patches/0004-leds-turris-omnia-change-max-brightness-from-255-to-.patch;
+ }{
+ name = "generic-Mangle-bootloader-s-kernel-arguments";
+ patch = ./kernel-patches/0005-generic-Mangle-bootloader-s-kernel-arguments.patch;
+ }{
+ name = "cpuidle-mvebu-indicate-failure-to-enter-deeper-sleep";
+ patch = ./kernel-patches/0006-cpuidle-mvebu-indicate-failure-to-enter-deeper-sleep.patch;
+ }{
+ name = "pci-mvebu-time-out-reset-on-link-up";
+ patch = ./kernel-patches/0007-pci-mvebu-time-out-reset-on-link-up.patch;
+ }{
+ name = "ARM-dts-mvebu-armada-385-turris-omnia-separate-dts-f";
+ patch = ./kernel-patches/0008-ARM-dts-mvebu-armada-385-turris-omnia-separate-dts-f.patch;
+ }{
+ name = "phy-marvell-phy-mvebu-a3700-comphy-Change-2500base-x";
+ patch = ./kernel-patches/0009-phy-marvell-phy-mvebu-a3700-comphy-Change-2500base-x.patch;
+ }{
+ name = "Rename-device-tree-for-Omnia-back-as-that-is-what-is";
+ patch = ./kernel-patches/0010-Rename-device-tree-for-Omnia-back-as-that-is-what-is.patch;
+ }];
+ };
+}