aboutsummaryrefslogtreecommitdiff
path: root/sentinel/faillogs/default.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-12-13 17:17:01 +0100
committerKarel Kočí <cynerd@email.cz>2021-12-13 17:17:01 +0100
commit001b0016acfeaeff22c2cef42ae72a1fa1fec0a4 (patch)
treeae949614800007b79b9b343c97ca1a8d32a31e0b /sentinel/faillogs/default.nix
downloadnixturris-001b0016acfeaeff22c2cef42ae72a1fa1fec0a4.tar.gz
nixturris-001b0016acfeaeff22c2cef42ae72a1fa1fec0a4.tar.bz2
nixturris-001b0016acfeaeff22c2cef42ae72a1fa1fec0a4.zip
Add Sentinel packages and needed libraries
Diffstat (limited to 'sentinel/faillogs/default.nix')
-rw-r--r--sentinel/faillogs/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/sentinel/faillogs/default.nix b/sentinel/faillogs/default.nix
new file mode 100644
index 0000000..d4bfa6b
--- /dev/null
+++ b/sentinel/faillogs/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, lib, fetchgit
+, bootstrapHook, pkg-config, gperf
+, logc, logc-libs, libevent, czmq, msgpack, libconfig
+}:
+
+stdenv.mkDerivation rec {
+ pname = "sentinel-faillogs";
+ version = "0.1.0";
+ meta = with lib; {
+ homepage = "https://gitlab.nic.cz/turris/sentinel/faillogs";
+ description = "Failed login attempt logs collector";
+ platforms = with platforms; linux;
+ license = licenses.gpl3;
+ };
+
+ src = fetchgit {
+ url = "https://gitlab.nic.cz/turris/sentinel/faillogs.git";
+ rev = "99ec41baed19cc1ca70490b2b8cd81784e7748d2";
+ sha256 = "1pp93z78qwg7arca5z70gdp5ja2jldk1rzig8r29a2fhjakd0hb2";
+ };
+
+ buildInputs = [logc logc-libs libevent czmq msgpack libconfig];
+ nativeBuildInputs = [bootstrapHook pkg-config gperf];
+}