aboutsummaryrefslogtreecommitdiff
path: root/pkgs/sentinel/fwlogs
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-12-21 18:49:02 +0100
committerKarel Kočí <cynerd@email.cz>2021-12-21 18:50:27 +0100
commite3e7eed22cf5f2db558477a0dfdd90e81e038122 (patch)
tree7951ec30f53f8124fff65292a2e1aa71732a0fde /pkgs/sentinel/fwlogs
parent001b0016acfeaeff22c2cef42ae72a1fa1fec0a4 (diff)
downloadnixturris-e3e7eed22cf5f2db558477a0dfdd90e81e038122.tar.gz
nixturris-e3e7eed22cf5f2db558477a0dfdd90e81e038122.tar.bz2
nixturris-e3e7eed22cf5f2db558477a0dfdd90e81e038122.zip
treewide: move packages to subdirectory
Diffstat (limited to 'pkgs/sentinel/fwlogs')
-rw-r--r--pkgs/sentinel/fwlogs/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/sentinel/fwlogs/default.nix b/pkgs/sentinel/fwlogs/default.nix
new file mode 100644
index 0000000..c388a76
--- /dev/null
+++ b/pkgs/sentinel/fwlogs/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, lib, fetchgit
+, bootstrapHook, pkg-config
+, czmq, msgpack, logc-0_1, logc-libs, libconfig, libnetfilter_log
+}:
+
+stdenv.mkDerivation rec {
+ pname = "sentinel-proxy";
+ version = "0.2.0";
+ meta = with lib; {
+ homepage = "https://gitlab.nic.cz/turris/sentinel/fwlogs";
+ description = "Firewall logs collector";
+ platforms = with platforms; linux;
+ license = licenses.gpl3;
+ };
+
+ src = fetchgit {
+ url = "https://gitlab.nic.cz/turris/sentinel/fwlogs.git";
+ rev = "v" + version;
+ sha256 = "04rlm3mlri2wz33z6jh2yh0p81lnrfpfmmfjrn4sfjwh1g21ins7";
+ };
+
+ buildInputs = [czmq msgpack logc-0_1 logc-libs libconfig libnetfilter_log];
+ nativeBuildInputs = [bootstrapHook pkg-config];
+}