aboutsummaryrefslogtreecommitdiff
path: root/pkgs/libraries/logc
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-12-21 18:49:02 +0100
committerKarel Kočí <cynerd@email.cz>2021-12-21 18:50:27 +0100
commite3e7eed22cf5f2db558477a0dfdd90e81e038122 (patch)
tree7951ec30f53f8124fff65292a2e1aa71732a0fde /pkgs/libraries/logc
parent001b0016acfeaeff22c2cef42ae72a1fa1fec0a4 (diff)
downloadnixturris-e3e7eed22cf5f2db558477a0dfdd90e81e038122.tar.gz
nixturris-e3e7eed22cf5f2db558477a0dfdd90e81e038122.tar.bz2
nixturris-e3e7eed22cf5f2db558477a0dfdd90e81e038122.zip
treewide: move packages to subdirectory
Diffstat (limited to 'pkgs/libraries/logc')
-rw-r--r--pkgs/libraries/logc/default.nix25
1 files changed, 25 insertions, 0 deletions
diff --git a/pkgs/libraries/logc/default.nix b/pkgs/libraries/logc/default.nix
new file mode 100644
index 0000000..1c99e19
--- /dev/null
+++ b/pkgs/libraries/logc/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, lib, fetchgit
+, bootstrapHook, pkg-config, gperf
+, libconfig
+, pkgversion ? "0.4.0", pkgsha256 ? "15nplgjgg6dxryy4yzbj4524y77ci0syi970rmbr955m9vxvhrib"
+}:
+
+stdenv.mkDerivation rec {
+ pname = "logc";
+ version = pkgversion;
+ meta = with lib; {
+ homepage = "https://gitlab.nic.cz/turris/logc";
+ description = "Logging for C";
+ platforms = with platforms; linux;
+ license = licenses.mit;
+ };
+
+ src = fetchgit {
+ url = "https://gitlab.nic.cz/turris/logc.git";
+ rev = "v" + version;
+ sha256 = pkgsha256;
+ };
+
+ buildInputs = [libconfig];
+ nativeBuildInputs = [bootstrapHook pkg-config gperf];
+}