aboutsummaryrefslogtreecommitdiff
path: root/pkgs/libraries/logc-libs
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-01-02 17:23:58 +0100
committerKarel Kočí <cynerd@email.cz>2022-04-12 21:48:06 +0200
commit5339e045194c5ad482250c0271959a5fd9f97db2 (patch)
tree44d068a2c15b4683f0eb124044bf8c59bda398d1 /pkgs/libraries/logc-libs
parent00e3489cc7ea1edc3e71aaa94a62efbd13d65e49 (diff)
downloadnixturris-5339e045194c5ad482250c0271959a5fd9f97db2.tar.gz
nixturris-5339e045194c5ad482250c0271959a5fd9f97db2.tar.bz2
nixturris-5339e045194c5ad482250c0271959a5fd9f97db2.zip
nios: Add sentinel module
Diffstat (limited to 'pkgs/libraries/logc-libs')
-rw-r--r--pkgs/libraries/logc-libs/0001-tests-cmzq-try-to-fix-test-failure.patch31
-rw-r--r--pkgs/libraries/logc-libs/default.nix7
2 files changed, 37 insertions, 1 deletions
diff --git a/pkgs/libraries/logc-libs/0001-tests-cmzq-try-to-fix-test-failure.patch b/pkgs/libraries/logc-libs/0001-tests-cmzq-try-to-fix-test-failure.patch
new file mode 100644
index 0000000..349bf91
--- /dev/null
+++ b/pkgs/libraries/logc-libs/0001-tests-cmzq-try-to-fix-test-failure.patch
@@ -0,0 +1,31 @@
+From ecd66fc7d0079093fc56c16233c1fb2e88879df3 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Karel=20Ko=C4=8D=C3=AD?= <karel.koci@nic.cz>
+Date: Thu, 24 Feb 2022 17:52:59 +0100
+Subject: [PATCH] tests/cmzq: try to fix test failure
+
+The errno seems to be possibly set by logc_czmq_init and thus we have to
+reset errno after that.
+---
+ tests/czmq.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/czmq.c b/tests/czmq.c
+index b6244d1..f25ab07 100644
+--- a/tests/czmq.c
++++ b/tests/czmq.c
+@@ -10,11 +10,11 @@ char *stderr_data;
+ size_t stderr_len;
+
+ void f_setup() {
+- errno = 0;
+ orig_stderr = stderr;
+ stderr = open_memstream(&stderr_data, &stderr_len);
+ logc_czmq_init();
+ log_set_level(log_czmq, LL_DEBUG);
++ errno = 0;
+ }
+ void f_teardown() {
+ ck_assert_int_eq(errno, 0);
+--
+2.35.1
+
diff --git a/pkgs/libraries/logc-libs/default.nix b/pkgs/libraries/logc-libs/default.nix
index 1fe7a18..f8e4a57 100644
--- a/pkgs/libraries/logc-libs/default.nix
+++ b/pkgs/libraries/logc-libs/default.nix
@@ -1,6 +1,7 @@
{ stdenv, lib, fetchgit
, bootstrapHook, pkg-config
, logc, czmq, libevent
+, check
}:
stdenv.mkDerivation rec {
@@ -9,7 +10,6 @@ stdenv.mkDerivation rec {
meta = with lib; {
homepage = "https://gitlab.nic.cz/turris/logc-libs";
description = "Logging for C";
- platforms = with platforms; linux;
license = licenses.mit;
};
@@ -21,4 +21,9 @@ stdenv.mkDerivation rec {
buildInputs = [logc czmq libevent];
nativeBuildInputs = [bootstrapHook pkg-config];
+ depsBuildBuild = [check];
+
+ doCheck = false; # TODO the test fails due to errno being set by czmq for some reason
+ doInstallCheck = false;
+ configureFlags = lib.optional (stdenv.hostPlatform == stdenv.buildPlatform) "--enable-tests";
}