aboutsummaryrefslogtreecommitdiff
path: root/nixos/nixos-modules-minfake.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-01-02 17:23:58 +0100
committerKarel Kočí <cynerd@email.cz>2022-04-12 21:48:06 +0200
commit5339e045194c5ad482250c0271959a5fd9f97db2 (patch)
tree44d068a2c15b4683f0eb124044bf8c59bda398d1 /nixos/nixos-modules-minfake.nix
parent00e3489cc7ea1edc3e71aaa94a62efbd13d65e49 (diff)
downloadnixturris-5339e045194c5ad482250c0271959a5fd9f97db2.tar.gz
nixturris-5339e045194c5ad482250c0271959a5fd9f97db2.tar.bz2
nixturris-5339e045194c5ad482250c0271959a5fd9f97db2.zip
nios: Add sentinel module
Diffstat (limited to 'nixos/nixos-modules-minfake.nix')
-rw-r--r--nixos/nixos-modules-minfake.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/nixos/nixos-modules-minfake.nix b/nixos/nixos-modules-minfake.nix
new file mode 100644
index 0000000..e7836cb
--- /dev/null
+++ b/nixos/nixos-modules-minfake.nix
@@ -0,0 +1,37 @@
+{ config, lib, pkgs, ... }:
+
+with lib;
+
+{
+
+ options = let
+
+ mkFake = {type, default}: mkOption {
+ type = type;
+ default = default;
+ description = "The module this option was part of was removed as part of Turris trim";
+ };
+ mkFakeList = type: mkFake {
+ type = types.listOf type;
+ default = [];
+ };
+
+ mkFakeDisable = mkOption {
+ type = types.bool;
+ default = false;
+ description = "The in default disabled option that was removed as part of Turris trim";
+ };
+
+ in {
+
+ services.xserver.enable = mkFakeDisable;
+ services.xserver.displayManager.hiddenUsers = mkFakeList types.str;
+ services.xserver.startGnuPGAgent = mkFakeDisable;
+
+ };
+
+ config = {
+ };
+}
+
+