aboutsummaryrefslogtreecommitdiff
path: root/nixos/modules/sentinel-fwlogs.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-04-09 09:44:39 +0200
committerKarel Kočí <cynerd@email.cz>2022-04-12 21:48:06 +0200
commit1c2206f46fc9f608f805071dd5e036d46249756d (patch)
treebbb44dbfc1575f228503afc1f58810edb0373e29 /nixos/modules/sentinel-fwlogs.nix
parent5339e045194c5ad482250c0271959a5fd9f97db2 (diff)
downloadnixturris-1c2206f46fc9f608f805071dd5e036d46249756d.tar.gz
nixturris-1c2206f46fc9f608f805071dd5e036d46249756d.tar.bz2
nixturris-1c2206f46fc9f608f805071dd5e036d46249756d.zip
treewide: move sentinel to the dedicated repository
Diffstat (limited to 'nixos/modules/sentinel-fwlogs.nix')
-rw-r--r--nixos/modules/sentinel-fwlogs.nix37
1 files changed, 0 insertions, 37 deletions
diff --git a/nixos/modules/sentinel-fwlogs.nix b/nixos/modules/sentinel-fwlogs.nix
deleted file mode 100644
index b7b056a..0000000
--- a/nixos/modules/sentinel-fwlogs.nix
+++ /dev/null
@@ -1,37 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-with lib;
-
-{
-
- imports = [ ./sentinel.nix ];
-
-
- options = {
-
- services.sentinel.fwlogs = {
- enable = mkOption {
- type = types.bool;
- default = true;
- description = ''
- Whether to enable the Turris Sentinel Firewall logs collector.
- The services.sentinel.enable has to be enabled as well.
- '';
- };
- };
- };
-
-
- config = mkIf config.services.sentinel.enable && config.services.sentinel.fwlogs.enable {
- environment.systemPackages = [ pkgs.sentinel-fwlogs ];
-
- systemd.services.sentinel-fwlogs = {
- description = "Turris Sentinel Firewall Logs";
- wantedBy = [ "multi-user.target" ];
- path = [ pkgs.sentinel-fwlogs ];
- serviceConfig.ExecStart = "${pkgs.sentinel-fwlogs}/bin/sentinel-fwlogs";
- };
-
- };
-
-}