aboutsummaryrefslogtreecommitdiff
path: root/medkit.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-04-09 18:54:00 +0200
committerKarel Kočí <cynerd@email.cz>2022-04-12 21:48:06 +0200
commitb1bd3d7b5cf5d2dfb94493bb73140e6d8210f401 (patch)
tree70f840066e93bea2058a0a79e618dc0337a4c724 /medkit.nix
parentfb73330d0ccdc50c79a8fe0675c51022ee64b367 (diff)
downloadnixturris-b1bd3d7b5cf5d2dfb94493bb73140e6d8210f401.tar.gz
nixturris-b1bd3d7b5cf5d2dfb94493bb73140e6d8210f401.tar.bz2
nixturris-b1bd3d7b5cf5d2dfb94493bb73140e6d8210f401.zip
Refactor Mox support
Diffstat (limited to 'medkit.nix')
-rw-r--r--medkit.nix45
1 files changed, 0 insertions, 45 deletions
diff --git a/medkit.nix b/medkit.nix
deleted file mode 100644
index aa93080..0000000
--- a/medkit.nix
+++ /dev/null
@@ -1,45 +0,0 @@
-board: { config, lib, pkgs, modulesPath, ... }: {
- imports = [
- "${toString modulesPath}/installer/cd-dvd/system-tarball.nix"
- ];
-
- boot.consoleLogLevel = lib.mkDefault 7;
- turris.device = "/dev/mmcblk1"; # TODO this is for mox and sd card only
-
- # Allow access to the root account right after installation
- users = {
- mutableUsers = false;
- users.root.password = "nixturris";
- };
-
- # TODO we have to generate the hardware specific configuration on first boot
- tarball.contents = [
- { source = pkgs.writeText "default-nixturris-flake" ''
- {
- inputs.nixturris.url = "git+git://cynerd.cz/nixturris.git";
- outputs = { self, nixturris }: {
- nixosConfigurations.nixturris = nixturris.lib.nixturrisSystem {
- board = "${board}";
- modules = [({ config, lib, pkgs, ... }: {
- # Optionally place your configuration here
- })];
- };
- };
- }
- '';
- target = "/etc/nixos/flake.nix";
- }
- { source = pkgs.writeText "medkit-extlinux" ''
- DEFAULT nixos-default
- TIMEOUT 0
- LABEL nixos-default
- MENU LABEL NixOS - Default
- FDTDIR /run/current-system/dtbs
- LINUX /run/current-system/kernel
- INITRD /run/current-system/initrd
- APPEND init=${config.system.build.toplevel}/init ${builtins.toString config.boot.kernelParams}
- '';
- target = "/boot/extlinux/extlinux.conf";
- }
- ];
-}