aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2022-05-06 13:21:31 +0200
committerKarel Kočí <cynerd@email.cz>2022-06-11 10:35:49 +0200
commite4045513a155b564926f4bb40e508bfcac9679ec (patch)
tree079ccf2d26e87f4830f9e09dda4d8a88830af878 /flake.nix
parentb2099a33684c998d7b3375677f338ba8d628b430 (diff)
downloadnixturris-e4045513a155b564926f4bb40e508bfcac9679ec.tar.gz
nixturris-e4045513a155b564926f4bb40e508bfcac9679ec.tar.bz2
nixturris-e4045513a155b564926f4bb40e508bfcac9679ec.zip
nixos/modules/hostapd: fork and expand hostapd
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix28
1 files changed, 15 insertions, 13 deletions
diff --git a/flake.nix b/flake.nix
index e3eb890..5225649 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,17 +1,17 @@
{
description = "Turris flake";
- outputs = { self, flake-utils, nixpkgs }: {
+ outputs = { self, flake-utils, nixpkgs }:
+ with flake-utils.lib;
+ let
+ supportedHostSystems = (
+ # Note: crossTarball* targets are broken on darwin so it gets disabled here
+ with builtins; filter (system: match ".*-darwin" system == null) defaultSystems
+ ) ++ [system.armv7l-linux];
+ in {
overlays.default = final: prev: import ./pkgs { nixpkgs = prev; };
- overlay = self.overlays.default; # Backward compatibility
-
- nixosModules = import ./nixos;
- nixosModule = {
- imports = builtins.attrValues self.nixosModules;
- nixpkgs.overlays = [ self.overlay ];
- };
-
+ nixosModules = import ./nixos self;
lib = import ./lib self;
nixosConfigurations = {
@@ -19,8 +19,9 @@
tarballOmnia = self.lib.nixturrisTarballSystem { board = "omnia"; nixpkgs = nixpkgs; };
};
- } // flake-utils.lib.eachSystem (flake-utils.lib.defaultSystems ++ ["armv7l-linux"]) (
+ } // eachSystem supportedHostSystems (
system: {
+
packages = let
tarball = nixos: nixos.config.system.build.tarball;
in {
@@ -31,7 +32,7 @@
crossTarballMox = tarball (self.lib.nixturrisTarballSystem { board = "mox"; nixpkgs = nixpkgs; system = system; });
crossTarballOmnia = tarball (self.lib.nixturrisTarballSystem { board = "omnia"; nixpkgs = nixpkgs; system = system; });
- } // flake-utils.lib.filterPackages system (flake-utils.lib.flattenTree (
+ } // filterPackages system (flattenTree (
import ./pkgs { nixpkgs = nixpkgs.legacyPackages."${system}"; }
));
@@ -39,9 +40,10 @@
# cross-compile those packages.
legacyPackages = import nixpkgs {
inherit system;
- overlays = [ self.overlay ];
- crossOverlays = [ self.overlay ];
+ overlays = [ self.overlays.default ];
+ crossOverlays = [ self.overlays.default ];
};
+
}
);
}