aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorKarel Kočí <cynerd@email.cz>2021-12-30 23:18:59 +0100
committerKarel Kočí <cynerd@email.cz>2022-01-02 15:28:44 +0100
commit794ed83a6c840703798b80503643025327e5c24d (patch)
tree5a374ac1f426995caa6d771943943fe5f27be6a0 /flake.nix
parente3e7eed22cf5f2db558477a0dfdd90e81e038122 (diff)
downloadnixturris-794ed83a6c840703798b80503643025327e5c24d.tar.gz
nixturris-794ed83a6c840703798b80503643025327e5c24d.tar.bz2
nixturris-794ed83a6c840703798b80503643025327e5c24d.zip
Convert to use flake.nix
The flakes are the future as it seems and thus it makes more sense to use that.
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..30f1a38
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,13 @@
+{
+ description = "Turris flake";
+
+ inputs.flake-utils.url = "github:numtide/flake-utils";
+
+ outputs = { self, nixpkgs, flake-utils }:
+ flake-utils.lib.eachSystem flake-utils.lib.allSystems (system: rec {
+ packages = import ./pkgs {
+ nixlib = nixpkgs.lib;
+ nixpkgs = nixpkgs.legacyPackages.${system};
+ };
+ });
+}